FONT causes form elements to behave improperly

VERIFIED FIXED in mozilla0.9.3

Status

()

Core
Layout: Form Controls
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Aaron Kaluszka, Assigned: rods (gone))

Tracking

Trunk
mozilla0.9.3
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
When FONT surrounds FORM, followed by SCRIPT, and focus is called, Mozilla puts
the cursor in whitespace.  When typing begins, the cursor positions itself
correctly, but the whitespace remains.  The problem disappears when FONT is
removed or closed before SCRIPT.

Build ID: 2001040904

Attaching testcase..
(Reporter)

Comment 1

17 years ago
Created attachment 30272 [details]
Testcase

Comment 2

17 years ago
Confirmed. I see this on build 2001040904 WinNT. After you load the testcase, 
you can't click into the field to position the cursor correctly. You have to 
start typing to get the cursor to jump to the field.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Created attachment 30273 [details]
form that works correctly (font tags removed)
over to layout.  This is not engine
Assignee: rogerl → karnaze
Component: Javascript Engine → Layout
QA Contact: pschwartau → petersen

Comment 5

17 years ago
Note that it isn't a JavaScript problem. Disable JavaScript and try to click in 
the field. You'll see the same misplaced cursor. It seems to occur anytime font 
surrounds an input element. This problem is gaining duplicates, such as bug 
75368 and bug 75080.
(Reporter)

Comment 6

17 years ago
changing description
Summary: FONT causes javascript.focus() to behave improperly → FONT causes form elements to behave improperly

Comment 7

17 years ago
*** Bug 75536 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
hello I tried wihch Aaron Kaluszka gave, this is real source of problem with
bug# 75080.

Comment 9

17 years ago
Reassigned to HTML Form Controls
Component: Layout → HTML Form Controls

Comment 10

17 years ago
*** Bug 76017 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
Reassigning to module owner.
Assignee: karnaze → rods
QA Contact: petersen → vladimire

Comment 12

17 years ago
It seems that 2001042304/Win2k works correctly.

Updated

17 years ago
Target Milestone: --- → mozilla0.9.3
(Reporter)

Comment 13

17 years ago
Verifying fixed on Build 20010522/WinXP
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
verifying 2001-05-24-04-trunk windows 98
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.