Last Comment Bug 754076 - WebApplicationMgmt onuninstall getter doesn't return value
: WebApplicationMgmt onuninstall getter doesn't return value
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Apps (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: David Chan [:dchan]
:
Mentors:
Depends on:
Blocks: 746465
  Show dependency treegraph
 
Reported: 2012-05-10 15:12 PDT by David Chan [:dchan]
Modified: 2012-07-28 09:23 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add return to get onuninstall (550 bytes, patch)
2012-05-10 15:36 PDT, David Chan [:dchan]
fabrice: review+
Details | Diff | Review

Description David Chan [:dchan] 2012-05-10 15:12:30 PDT
314   get onuninstall() {
315     this._onuninstall;
316   },

The above code is different from the oninstall getter() a couple lines above. I'm not sure if this was intended or not.

http://mxr.mozilla.org/mozilla-central/source/dom/base/Webapps.js#314
Comment 1 David Chan [:dchan] 2012-05-10 15:36:13 PDT
Created attachment 622943 [details] [diff] [review]
Add return to get onuninstall

Patch againt services-central
Comment 2 [:fabrice] Fabrice Desré 2012-05-10 19:48:07 PDT
Comment on attachment 622943 [details] [diff] [review]
Add return to get onuninstall

Review of attachment 622943 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! Please land that on mozilla-inbound
Comment 3 Sid Stamm [:geekboy or :sstamm] 2012-05-11 15:30:25 PDT
Pushed to inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/97b28a637e8b
Comment 4 David Chan [:dchan] 2012-05-11 15:34:03 PDT
(In reply to Sid Stamm [:geekboy] from comment #3)
> Pushed to inbound:
> http://hg.mozilla.org/integration/mozilla-inbound/rev/97b28a637e8b

Thanks for landing this Sid
Comment 5 Matt Brubeck (:mbrubeck) 2012-05-12 09:03:25 PDT
https://hg.mozilla.org/mozilla-central/rev/97b28a637e8b

Note You need to log in before you can comment on or make changes to this bug.