Intermittent Windows crashtest crash [@ mozilla::BlockingResourceBase::CheckAcquire] [@ mozilla::MediaStreamGraphImpl::EnsureNextIteration()] in 371124-1.html, 371124-2.html, 462947.html,

RESOLVED DUPLICATE of bug 753852

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 753852
7 years ago
7 years ago

People

(Reporter: philor, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

https://tbpl.mozilla.org/php/getParsedLog.php?id=11649060&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test crashtest on 2012-05-10 11:20:05 PDT for push af2b5a6acb96
slave: talos-r3-xp-066

This GL context (06980F88) is owned by thread 030AE728, but the current thread is 09A9F310. That's fine by itself, but our current code in GLContext::MakeCurrent, checking if the context is already current, relies on the assumption that GL calls on a given GLContext are only made by the thread that created that GLContext. If you want to start making GL calls from non-owning threads, you'll have to change a few things around here, see Bug 749678 comments 13 and 15.
###!!! ABORT: file e:\builds\moz2_slave\m-in-w32-dbg\build\obj-firefox\dist\include\GLContext.h, line 698
TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/dom/base/crashtests/371124-2.html | Exited with code -2147483645 during test run
INFO | automation.py | Application ran for: 0:02:24.532000
INFO | automation.py | Reading PID log: c:\docume~1\cltbld\locals~1\temp\tmp6qn2hopidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32-debug/1336668264/firefox-15.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | file:///C:/talos-slave/test/build/reftest/tests/dom/base/crashtests/371124-2.html | application crashed (minidump found)
Crash dump filename: c:\docume~1\cltbld\locals~1\temp\tmpjoq_4r\minidumps\0f0202a8-d2f0-478a-9f89-e4c0db5d5b11.dmp
Operating system: Windows NT
                  5.1.2600 Service Pack 2
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ
Crash address: 0x4c

Thread 26 (crashed)
 0  xul.dll!mozilla::BlockingResourceBase::CheckAcquire(mozilla::CallStack const &) [BlockingResourceBase.cpp:af2b5a6acb96 : 130 + 0x0]
    eip = 0x01f583aa   esp = 0x0bdffdb8   ebp = 0x0bdffe18   ebx = 0x0915ff68
    esi = 0x00000048   edi = 0x00000048   eax = 0xb0ef718a   ecx = 0x00000048
    edx = 0x030a6f2c   efl = 0x00010282
    Found by: given as instruction pointer in context
 1  xul.dll!mozilla::Mutex::Lock() [BlockingResourceBase.cpp:af2b5a6acb96 : 260 + 0xa]
    eip = 0x01f584c8   esp = 0x0bdffe20   ebp = 0x0bdffe2c
    Found by: call frame info
 2  xul.dll!mozilla::MediaStreamGraphImpl::EnsureNextIteration() [MediaStreamGraph.cpp:af2b5a6acb96 : 1211 + 0xc]
    eip = 0x019aaa07   esp = 0x0bdffe34   ebp = 0x0bdffe40
    Found by: call frame info
 3  xul.dll!mozilla::SourceMediaStream::EndTrack(int) [MediaStreamGraph.cpp:af2b5a6acb96 : 1870 + 0xa]
    eip = 0x019abf6f   esp = 0x0bdffe48   ebp = 0x0bdffe54
    Found by: call frame info
 4  xul.dll!nsBuiltinDecoderStateMachine::FinishOutputStreams() [nsBuiltinDecoderStateMachine.cpp:af2b5a6acb96 : 745 + 0x8]
    eip = 0x019b6b32   esp = 0x0bdffe5c   ebp = 0x0bdffe74
    Found by: call frame info
 5  xul.dll!nsBuiltinDecoderStateMachine::RunStateMachine() [nsBuiltinDecoderStateMachine.cpp:af2b5a6acb96 : 2047 + 0x6]
    eip = 0x019bb600   esp = 0x0bdffe7c   ebp = 0x0bdffec0
    Found by: call frame info
 6  xul.dll!nsBuiltinDecoderStateMachine::CallRunStateMachine() [nsBuiltinDecoderStateMachine.cpp:af2b5a6acb96 : 2547 + 0x17]
    eip = 0x019bbb40   esp = 0x0bdffec8   ebp = 0x0bdffedc
    Found by: call frame info
 7  xul.dll!nsBuiltinDecoderStateMachine::Run() [nsBuiltinDecoderStateMachine.cpp:af2b5a6acb96 : 2529 + 0x6]
    eip = 0x019bbc27   esp = 0x0bdffed8   ebp = 0x0bdffedc
    Found by: stack scanning

https://tbpl.mozilla.org/php/getParsedLog.php?id=11650602&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound debug test crashtest on 2012-05-10 12:07:10 PDT for push d8e4e9519516
slave: talos-r3-w7-022

WARNING: No outer window available!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 8446
TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/dom/base/crashtests/462947.html | Exited with code -1073741819 during test run
INFO | automation.py | Application ran for: 0:02:46.584000
INFO | automation.py | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpgi2ep_pidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32-debug/1336670421/firefox-15.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | file:///c:/talos-slave/test/build/reftest/tests/dom/base/crashtests/462947.html | application crashed (minidump found)
Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpc7cdi-\minidumps\12c5749b-3f84-4b89-9918-2fefac61812d.dmp
Operating system: Windows NT
                  6.1.7600 
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ
Crash address: 0x4c

Thread 26 (crashed)
 0  xul.dll!mozilla::BlockingResourceBase::CheckAcquire(mozilla::CallStack const &) [BlockingResourceBase.cpp:d8e4e9519516 : 130 + 0x0]
    eip = 0x67f783aa   esp = 0x09ccfc3c   ebp = 0x09ccfc9c   ebx = 0x06702508
    esi = 0x00000048   edi = 0x00000048   eax = 0x47b034f9   ecx = 0x00000048
    edx = 0x00000000   efl = 0x00010206
    Found by: given as instruction pointer in context
 1  xul.dll!mozilla::Mutex::Lock() [BlockingResourceBase.cpp:d8e4e9519516 : 260 + 0xa]
    eip = 0x67f784c8   esp = 0x09ccfca4   ebp = 0x09ccfcb0
    Found by: call frame info
 2  xul.dll!mozilla::MediaStreamGraphImpl::EnsureNextIteration() [MediaStreamGraph.cpp:d8e4e9519516 : 1211 + 0xc]
    eip = 0x679caa07   esp = 0x09ccfcb8   ebp = 0x09ccfcc4
    Found by: call frame info
 3  xul.dll!mozilla::SourceMediaStream::EndTrack(int) [MediaStreamGraph.cpp:d8e4e9519516 : 1870 + 0xa]
    eip = 0x679cbf6f   esp = 0x09ccfccc   ebp = 0x09ccfcd8
    Found by: call frame info
 4  xul.dll!nsBuiltinDecoderStateMachine::FinishOutputStreams() [nsBuiltinDecoderStateMachine.cpp:d8e4e9519516 : 745 + 0x8]
    eip = 0x679d6b32   esp = 0x09ccfce0   ebp = 0x09ccfcf8
    Found by: call frame info
 5  xul.dll!nsBuiltinDecoderStateMachine::RunStateMachine() [nsBuiltinDecoderStateMachine.cpp:d8e4e9519516 : 2047 + 0x6]
    eip = 0x679db600   esp = 0x09ccfd00   ebp = 0x09ccfd44
    Found by: call frame info
 6  xul.dll!nsBuiltinDecoderStateMachine::CallRunStateMachine() [nsBuiltinDecoderStateMachine.cpp:d8e4e9519516 : 2547 + 0x17]
    eip = 0x679dbb40   esp = 0x09ccfd4c   ebp = 0x09ccfd60
    Found by: call frame info
 7  xul.dll!nsBuiltinDecoderStateMachine::Run() [nsBuiltinDecoderStateMachine.cpp:d8e4e9519516 : 2529 + 0x6]
    eip = 0x679dbc27   esp = 0x09ccfd5c   ebp = 0x09ccfd60
    Found by: stack scanning

https://tbpl.mozilla.org/php/getParsedLog.php?id=11655988&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound debug test crashtest on 2012-05-10 14:53:28 PDT for push 4da3ac9ee729
slave: talos-r3-w7-020

TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/dom/base/crashtests/371124-1.html | Exited with code -1073741819 during test run
INFO | automation.py | Application ran for: 0:02:43.746000
INFO | automation.py | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpdto-pbpidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32-debug/1336676961/firefox-15.0a1.en-US.win32.crashreporter-symbols.zip
PROCESS-CRASH | file:///c:/talos-slave/test/build/reftest/tests/dom/base/crashtests/371124-1.html | application crashed (minidump found)
Crash dump filename: c:\users\cltbld\appdata\local\temp\tmp7khafi\minidumps\0c29c725-5be9-439e-bd45-8af1a9e97a1c.dmp
Operating system: Windows NT
                  6.1.7600 
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ
Crash address: 0x4c

Thread 26 (crashed)
 0  xul.dll!mozilla::BlockingResourceBase::CheckAcquire(mozilla::CallStack const &) [BlockingResourceBase.cpp:4da3ac9ee729 : 130 + 0x0]
    eip = 0x6a157bb5   esp = 0x0f74fc94   ebp = 0x0f74fcf4   ebx = 0x074fe910
    esi = 0x00000048   edi = 0x00000048   eax = 0x9432fd69   ecx = 0x00000048
    edx = 0x00000000   efl = 0x00010286
    Found by: given as instruction pointer in context
 1  xul.dll!mozilla::Mutex::Lock() [BlockingResourceBase.cpp:4da3ac9ee729 : 260 + 0xa]
    eip = 0x6a157cd3   esp = 0x0f74fcfc   ebp = 0x0f74fd08
    Found by: call frame info
 2  xul.dll!mozilla::MediaStreamGraphImpl::EnsureNextIteration() [MediaStreamGraph.cpp:4da3ac9ee729 : 1211 + 0xc]
    eip = 0x69baa275   esp = 0x0f74fd10   ebp = 0x0f74fd1c
    Found by: call frame info
 3  xul.dll!mozilla::SourceMediaStream::EndTrack(int) [MediaStreamGraph.cpp:4da3ac9ee729 : 1870 + 0xa]
    eip = 0x69bab7de   esp = 0x0f74fd24   ebp = 0x0f74fd30
    Found by: call frame info
 4  xul.dll!nsBuiltinDecoderStateMachine::FinishOutputStreams() [nsBuiltinDecoderStateMachine.cpp:4da3ac9ee729 : 745 + 0x8]
    eip = 0x69bb63a1   esp = 0x0f74fd38   ebp = 0x0f74fd50
    Found by: call frame info
 5  xul.dll!nsBuiltinDecoderStateMachine::RunStateMachine() [nsBuiltinDecoderStateMachine.cpp:4da3ac9ee729 : 2047 + 0x6]
    eip = 0x69bbae6d   esp = 0x0f74fd58   ebp = 0x0f74fd9c
    Found by: call frame info
 6  xul.dll!nsBuiltinDecoderStateMachine::CallRunStateMachine() [nsBuiltinDecoderStateMachine.cpp:4da3ac9ee729 : 2547 + 0x17]
    eip = 0x69bbb3ad   esp = 0x0f74fda4   ebp = 0x0f74fdb8
    Found by: call frame info
 7  xul.dll!nsBuiltinDecoderStateMachine::Run() [nsBuiltinDecoderStateMachine.cpp:4da3ac9ee729 : 2529 + 0x6]
    eip = 0x69bbb494   esp = 0x0f74fdb4   ebp = 0x0f74fdb8
    Found by: stack scanning
See also bug 753852, happy to dupe whichever way makes more sense; this bug has more diagnosis etc.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Version: 13 Branch → Trunk
Duplicate of bug: 753852
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.