Last Comment Bug 754138 - Rect.h generates lots of warnings when building content and layout
: Rect.h generates lots of warnings when building content and layout
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: David Zbarsky (:dzbarsky)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 17:57 PDT by David Zbarsky (:dzbarsky)
Modified: 2012-05-15 06:34 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (830 bytes, patch)
2012-05-10 17:57 PDT, David Zbarsky (:dzbarsky)
roc: review+
Details | Diff | Splinter Review
Patch r=roc (848 bytes, patch)
2012-05-12 17:11 PDT, David Zbarsky (:dzbarsky)
bas: review+
Details | Diff | Splinter Review

Description David Zbarsky (:dzbarsky) 2012-05-10 17:57:39 PDT
Created attachment 622995 [details] [diff] [review]
Patch

I haven't run this on tryserver yet because my account is disabled, but I will as soon as I can.
Comment 1 David Zbarsky (:dzbarsky) 2012-05-12 17:11:49 PDT
Created attachment 623467 [details] [diff] [review]
Patch r=roc
Comment 2 Bas Schouten (:bas.schouten) 2012-05-12 21:00:00 PDT
Comment on attachment 623467 [details] [diff] [review]
Patch r=roc

Review of attachment 623467 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/2d/Rect.h
@@ +88,5 @@
>      {
>        *aOut = IntRect(int32_t(X()), int32_t(Y()),
>                      int32_t(Width()), int32_t(Height()));
> +      return Rect(float(aOut->x), float(aOut->y), 
> +                  float(aOut->width), float(aOut->height)).IsEqualEdges(*this);

I'd suggest using Float, the actual type of Rect().
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-05-14 15:57:13 PDT
Comment on attachment 623467 [details] [diff] [review]
Patch r=roc

You can just use checkin-needed for single-patch bugs like this.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-05-14 16:02:21 PDT
Pushed with comment 2 addressed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/0623ff91509e
Comment 5 Ed Morley [:emorley] 2012-05-15 06:34:05 PDT
https://hg.mozilla.org/mozilla-central/rev/0623ff91509e

Note You need to log in before you can comment on or make changes to this bug.