Closed Bug 754162 Opened 8 years ago Closed 8 years ago

Shutdown hang in nsHttpConnectionMgr::Shutdown() / PSM HandshakeCallback()

Categories

(Core :: Networking: HTTP, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 729536

People

(Reporter: Dolske, Unassigned)

Details

Attachments

(1 file)

Just happened on a ~3 day old OS X Nightly. Hung on shutdown, repeated samples were the same. I can't help by wonder why this work is even happening on shutdown!

Attaching stack in a moment.
Attached file Hang stack
Nice; we have the main thread waiting for a runnable it posted to the socket thread to finish. Meanwhile, the socket thread has dispatched a runnable to the main thread, and is waiting for it to finish.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729536
You need to log in before you can comment on or make changes to this bug.