Last Comment Bug 754169 - Intermittent test_bug549262.html | Page is scrolled up - got 568, expected 0 and | Page is not scrolled down - got 27, expected 0
: Intermittent test_bug549262.html | Page is scrolled up - got 568, expected 0 ...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on:
Blocks: 438871 549262
  Show dependency treegraph
 
Reported: 2012-05-10 21:50 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (196 bytes, patch)
2012-07-16 06:09 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details | Diff | Review
Patch (2.74 KB, patch)
2012-07-16 06:10 PDT, Jared Wein [:jaws] (please needinfo? me)
ehsan: review+
Details | Diff | Review

Description Phil Ringnalda (:philor) 2012-05-10 21:50:29 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=11662874&tree=Mozilla-Inbound
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitests-4/5 on 2012-05-10 18:53:39 PDT for push ae9aef30b549
slave: talos-r4-lion-073

5630 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 568, expected 0
5631 INFO TEST-PASS | /tests/editor/libeditor/html/tests/test_bug549262.html | The content of the editable element has not changed - abc should equal abc
5632 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 27, expected 0
Comment 1 Treeherder Robot 2012-05-12 07:41:37 PDT
ttaubert
https://tbpl.mozilla.org/php/getParsedLog.php?id=11702714&tree=Fx-Team
Rev4 MacOSX Lion 10.7 fx-team debug test mochitests-4/5 on 2012-05-12 05:12:36
slave: talos-r4-lion-033

5630 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 568, expected 0
5632 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 27, expected 0
Comment 2 Treeherder Robot 2012-05-15 06:41:08 PDT
bbondy
https://tbpl.mozilla.org/php/getParsedLog.php?id=11751226&tree=Try
Rev3 WINNT 6.1 try debug test mochitests-4/5 on 2012-05-14 22:43:22
slave: talos-r3-w7-017

5620 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 562, expected 0
5622 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 28, expected 0
Comment 3 Treeherder Robot 2012-05-16 01:42:32 PDT
jacek
https://tbpl.mozilla.org/php/getParsedLog.php?id=11791779&tree=Mozilla-Inbound
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitests-4/5 on 2012-05-16 01:23:35
slave: talos-r4-lion-060

5630 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 568, expected 0
5632 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 27, expected 0
5638 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up
5642 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled down
5643 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 576, expected 8
14192 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_flush_on_paint.html | Check that we set width before painting - got 212, expected 213
Comment 4 Treeherder Robot 2012-05-22 12:57:31 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11956900&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound debug test mochitests-4/5 on 2012-05-22 12:33:27
slave: talos-r3-w7-039

5669 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 562, expected 0
5671 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 28, expected 0
Comment 5 Treeherder Robot 2012-05-28 09:28:51 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=12133198&tree=Mozilla-Inbound
Rev4 MacOSX Lion 10.7 mozilla-inbound debug test mochitests-4/5 on 2012-05-28 09:01:34
slave: talos-r4-lion-033

6141 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 568, expected 0
6143 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 27, expected 0
Comment 6 Treeherder Robot 2012-06-07 12:19:25 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12460409&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitests-4/5 on 2012-06-07 11:54:43
slave: talos-r4-snow-077

6138 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 568, expected 0
6140 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 27, expected 0
Comment 7 Treeherder Robot 2012-06-18 22:07:17 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12777878&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitests-4/5 on 2012-06-18 21:39:07
slave: talos-r4-snow-013

6144 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 568, expected 0
6146 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 27, expected 0
Comment 8 Treeherder Robot 2012-06-22 05:00:25 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=12896321&tree=Firefox
Rev4 MacOSX Lion 10.7 mozilla-central opt test mochitests-4/5 on 2012-06-22 04:25:04
slave: talos-r4-lion-040

6826 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled down - didn't expect 0, but got it
Comment 9 Treeherder Robot 2012-06-24 12:39:18 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=12955311&tree=Mozilla-Inbound
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitests-4/5 on 2012-06-24 12:21:34
slave: talos-r4-lion-071

6826 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled down - didn't expect 0, but got it
Comment 10 Ed Morley [:emorley] 2012-06-27 04:47:13 PDT
I've broken out the failures in comment 8 & comment 9 to bug 768838.
Comment 11 :Ehsan Akhgari (busy, don't ask for review please) 2012-06-27 10:03:47 PDT
I suspect that this might have something to do with smooth scrolling.  Jared, any chance you can take a look please?
Comment 12 Jared Wein [:jaws] (please needinfo? me) 2012-06-27 11:50:50 PDT
Yeah, I can take a look, but it is low on my priority list currently.
Comment 13 Treeherder Robot 2012-06-29 15:11:00 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13114704&tree=Firefox
Rev3 Fedora 12x64 mozilla-central debug test mochitests-4/5 on 2012-06-29 14:44:28
slave: talos-r3-fed64-018

6812 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 562, expected 0
6814 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 27, expected 0
Comment 14 Treeherder Robot 2012-07-03 13:42:55 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=13202254&tree=Mozilla-Inbound
Rev3 WINNT 6.1 mozilla-inbound pgo test mochitests-4/5 on 2012-07-03 12:49:23
slave: talos-r3-w7-036

6812 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 562, expected 0
6814 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 28, expected 0
15319 ERROR TEST-UNEXPECTED-FAIL | /tests/layout/base/tests/test_reftests_with_caret.html | Reftest http://mochi.test:8888/tests/layout/base/tests/bug644428-1.html FAILED
Comment 15 Treeherder Robot 2012-07-12 05:57:45 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=13456914&tree=Mozilla-Inbound
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitests-4/5 on 2012-07-12 05:22:13
slave: talos-r4-lion-013

6826 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled down - didn't expect 0, but got it
6828 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled up - didn't expect 0, but got it
6831 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled up - got 27, expected 520
6834 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled down
Comment 16 Jared Wein [:jaws] (please needinfo? me) 2012-07-16 06:09:09 PDT
Created attachment 642552 [details] [diff] [review]
Patch

I am unable to reproduce the oranges locally, but these changes should fix them.
Comment 17 Jared Wein [:jaws] (please needinfo? me) 2012-07-16 06:10:25 PDT
Created attachment 642554 [details] [diff] [review]
Patch

Non-empty patch this time :)
Comment 18 Jared Wein [:jaws] (please needinfo? me) 2012-07-17 08:42:03 PDT
Pushed to mozilla-inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e232349d1c64
Comment 19 Ed Morley [:emorley] 2012-07-18 05:57:13 PDT
https://hg.mozilla.org/mozilla-central/rev/e232349d1c64
Comment 20 Treeherder Robot 2012-08-15 16:25:06 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=14416094&tree=Mozilla-Aurora
Rev3 WINNT 5.1 mozilla-aurora debug test mochitests-4/5 on 2012-08-15 15:24:21
slave: talos-r3-xp-068

6838 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is scrolled up - got 562, expected 0
6840 ERROR TEST-UNEXPECTED-FAIL | /tests/editor/libeditor/html/tests/test_bug549262.html | Page is not scrolled down - got 28, expected 0

Note You need to log in before you can comment on or make changes to this bug.