Closed Bug 754175 Opened 7 years ago Closed 7 years ago

Intermittent browser_tilt_04_initialization-key.js | application timed out after 330 seconds with no output

Categories

(DevTools :: Inspector, defect, major)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 754806

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [test which aborts the suite][tilt])

https://tbpl.mozilla.org/php/getParsedLog.php?id=11650382&tree=Firefox
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2012-05-10 11:36:35 PDT for push 0abed8c2714f
slave: talos-r3-fed-072

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_04_initialization-key.js | Pressing the accesskey should open Tilt.
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_04_initialization-key.js | Console message: [JavaScript Warning: "Error: WebGL: GL error 0x505 occurred during OpenGL context initialization, before WebGL initialization!" {file: "resource:///modules/devtools/TiltGL.jsm" line: 1614}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_04_initialization-key.js | Console message: [JavaScript Warning: "Error: WebGL: Error during OpenGL initialization" {file: "resource:///modules/devtools/TiltGL.jsm" line: 1614}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_04_initialization-key.js | Console message: [JavaScript Warning: "Error: WebGL: GL error 0x505 occurred during OpenGL context initialization, before WebGL initialization!" {file: "resource:///modules/devtools/TiltGL.jsm" line: 1614}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_04_initialization-key.js | Console message: [JavaScript Warning: "Error: WebGL: Error during OpenGL initialization" {file: "resource:///modules/devtools/TiltGL.jsm" line: 1614}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_04_initialization-key.js | Console message: [JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMHTMLCanvasElement.getContext]"]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/tilt/test/browser_tilt_04_initialization-key.js | application timed out after 330 seconds with no output
(Screenshot of a dialog open over the browser window, telling the test harness to "please check the troubleshooting information available at http://get.webgl.org/troubleshooting" despite its inability to read)

If there's something to test for, might be good to throw in an explicit test rather than just waiting to time out and aborting the entire test suite.
Whiteboard: [orange][test which aborts the suite] → [orange][test which aborts the suite][tilt]
Blocks: 755168
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 754806
Whiteboard: [orange][test which aborts the suite][tilt] → [test which aborts the suite][tilt]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.