Install any xpi results in crash

VERIFIED DUPLICATE of bug 75388

Status

Core Graveyard
Installer: XPInstall Engine
--
blocker
VERIFIED DUPLICATE of bug 75388
17 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: dbragg)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 2001-04-10-09-trunk(WIN), 2001-04-10-08-trunk(MAC), 
2001-04-10-08-trunk(LINUX)

1. From http://jimbob/trigger3.html, click Trigger case button to install
   any xpi package
2. Click OK button from confirm dialog

RESULT:
Browser crashes immediately.

EXPECTED RESULT:
Install a file.

NOTE:
Win 98 crashes.  But Win NT does not crash.  Mac and Linux crash.  Builds from 
4/9/2001 do not crash.

TalkBack Incident ID = 28922206

Stack Trace

nsImageBoxFrame::OnStartContainer 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsImageBoxFrame.cpp, line 643] 
nsImageListener::OnStopFrame 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsImageFrame.cpp, line 1755] 
imgRequestProxy::OnStartContainer 
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgRequestProxy.cpp, line 256] 
imgRequest::AddObserver 
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgRequest.cpp, line 107] 
imgRequestProxy::Init 
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgRequestProxy.cpp, line 97] 
imgLoader::LoadImage 
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgLoader.cpp, line 169] 
nsImageBoxFrame::UpdateImage 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsImageBoxFrame.cpp, line 362] 
nsImageBoxFrame::DidSetStyleContext 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsImageBoxFrame.cpp, line 470] 
nsFrame::SetStyleContext 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, line 478] 
nsFrame::Init [d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrame.cpp, 
line 329] 
nsLeafBoxFrame::Init 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsLeafBoxFrame.cpp, line 95] 
nsImageBoxFrame::Init 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsImageBoxFrame.cpp, line 211] 
nsCSSFrameConstructor::InitAndRestoreFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 6671] 
nsCSSFrameConstructor::ConstructXULFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 5798] 
nsCSSFrameConstructor::ConstructFrameInternal 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 7198] 
nsCSSFrameConstructor::ConstructFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 7100] 
nsCSSFrameConstructor::ProcessChildren 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 11232] 
nsCSSFrameConstructor::ConstructXULFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 5825] 
nsCSSFrameConstructor::ConstructFrameInternal 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 7198] 
nsCSSFrameConstructor::ConstructFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 7100] 
nsCSSFrameConstructor::ProcessChildren 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 11232] 
nsCSSFrameConstructor::ConstructXULFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 5825] 
nsCSSFrameConstructor::ConstructFrameInternal 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 7198] 
nsCSSFrameConstructor::ConstructFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 7100] 
nsCSSFrameConstructor::ProcessChildren 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 11232] 
nsCSSFrameConstructor::ConstructDocElementFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 3539] 
nsCSSFrameConstructor::ContentInserted 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 8410] 
StyleSetImpl::ContentInserted 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1224] 
PresShell::InitialReflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2468] 
nsXULDocument::StartLayout 
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
3920] 
nsXULDocument::ResumeWalk 
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
5025] 
nsXULDocument::OnStreamComplete 
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
5167] 
nsStreamLoader::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 122] 
nsJARChannel::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 
587] 
nsOnStopRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 
159] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 589] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 522] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
1070] 
KERNEL32.DLL + 0x242e7 (0xbff942e7) 
0x00688b5a
(Reporter)

Comment 1

17 years ago
Adding keywords crash and nsbeta1.  Help!
Keywords: crash, nsbeta1

*** This bug has been marked as a duplicate of 75388 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
No longer happening.  Marking Verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.