Last Comment Bug 754196 - <SELECT> drop-down list scrolls with mouse wheel unwillingly if you move mouse pointer at the same time
: <SELECT> drop-down list scrolls with mouse wheel unwillingly if you move mou...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 15 Branch
: x86 All
: -- normal (vote)
: mozilla15
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 754520 681192
  Show dependency treegraph
 
Reported: 2012-05-11 01:18 PDT by Alice0775 White
Modified: 2012-05-24 21:53 PDT (History)
6 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
unaffected


Attachments
sample (4.26 KB, text/html)
2012-05-11 01:18 PDT, Alice0775 White
no flags Details
fix (3.08 KB, patch)
2012-05-14 17:27 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
mats: review+
Details | Diff | Review

Description Alice0775 White 2012-05-11 01:18:04 PDT
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/d37d4edce6dd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510145529

<SELECT> drop-down list scrolls with  mouse wheel unwillingly if you move mouse pointer at the same time

Reproducible: Always

Steps to Reproduce:
1. Open attached
2. Open drop down list by click <SELECT> field
3. Try to scroll the list with mouse wheel and move mouse pointer at the same time


 
Actual Results:
  would not scroll

Expected Results:
  should scroll

Regression window(m-c)
works:
http://hg.mozilla.org/mozilla-central/rev/6fe7dd2f8f57
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510021321
fails:
http://hg.mozilla.org/mozilla-central/rev/b7b6565d12a0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120510050721
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fe7dd2f8f57&tochange=b7b6565d12a0



Regression window(m-i)
works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b5304fd23df9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120509222721
fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/67091352b7d2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120509223521
pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b5304fd23df9&tochange=67091352b7d2

Regressed by: Bug 681192
Comment 1 Alice0775 White 2012-05-11 01:18:26 PDT
Created attachment 623061 [details]
sample
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-14 17:27:58 PDT
Created attachment 623883 [details] [diff] [review]
fix
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-14 17:29:27 PDT
Thanks Alice for filing the bug!

For regressions that you think should be fixed before release, please add tracking-firefox-? flags. Thanks!!!
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-14 17:31:07 PDT
I think this fixes bug 754520 as well.
Comment 5 Mats Palmgren (:mats) 2012-05-15 04:01:09 PDT
Comment on attachment 623883 [details] [diff] [review]
fix

r=mats
Comment 6 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-15 22:55:14 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/80fa9af29d8a
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-05-16 19:27:20 PDT
https://hg.mozilla.org/mozilla-central/rev/80fa9af29d8a

Should this have a test?
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-16 20:55:53 PDT
Yes, but writing a reliable test would not be easy...
Comment 9 Alex Keybl [:akeybl] 2012-05-21 16:09:31 PDT
The status flags are a bit confusing since 14 isn't actually affected until bug 681192 is uplifted to Aurora (if it's uplifted). Tracking nonetheless.
Comment 10 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-05-24 21:53:46 PDT
Bug 681192 is not being uplifted to Aurora (and if it was, we'd uplift this fix along with it).

Note You need to log in before you can comment on or make changes to this bug.