Last Comment Bug 754218 - crash in nsFrameScriptExecutor::Traverse
: crash in nsFrameScriptExecutor::Traverse
Status: RESOLVED FIXED
[fixed by bug 673148]
: crash
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86 Windows NT
: -- critical (vote)
: mozilla15
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: async-webconsole
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 02:59 PDT by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2012-06-02 04:03 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2012-05-11 02:59:24 PDT
I got this crash with a trunk build of 2012-05-05 and restarting after I installed the Remote XUL Manager.

This bug was filed from the Socorro interface and is 
report bp-e5de6b0d-61ac-4cce-95f3-816442120511 .
============================================================= 
0 	xul.dll 	nsFrameScriptExecutor::Traverse 	content/base/src/nsFrameMessageManager.cpp:904
1 	xul.dll 	nsInProcessTabChildGlobal::cycleCollection::Traverse 	content/base/src/nsInProcessTabChildGlobal.cpp:155
2 	xul.dll 	GCGraphBuilder::Traverse 	xpcom/base/nsCycleCollector.cpp:1789
3 	xul.dll 	nsCycleCollector::MarkRoots 	xpcom/base/nsCycleCollector.cpp:2100
4 	xul.dll 	nsCycleCollector::BeginCollection 	xpcom/base/nsCycleCollector.cpp:3059
5 	xul.dll 	nsCycleCollector::Collect 	xpcom/base/nsCycleCollector.cpp:2998
6 	xul.dll 	nsCycleCollector::Shutdown 	xpcom/base/nsCycleCollector.cpp:3166
7 	xul.dll 	nsCycleCollector_shutdown 	xpcom/base/nsCycleCollector.cpp:3531
8 	xul.dll 	mozilla::ShutdownXPCOM 	xpcom/build/nsXPComInit.cpp:675
9 	xul.dll 	ScopedXPCOMStartup::~ScopedXPCOMStartup 	toolkit/xre/nsAppRunner.cpp:1129
10 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3879
11 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3933
12 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
13 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
14 	kernel32.dll 	BaseThreadInitThunk 	
15 	ntdll.dll 	__RtlUserThreadStart 	
16 	ntdll.dll 	_RtlUserThreadStart
Comment 1 Josh Matthews [:jdm] 2012-05-11 03:07:00 PDT
This looks like it will be fixed by the "part 0" patch in bug 673148.

Note You need to log in before you can comment on or make changes to this bug.