Last Comment Bug 754292 - Make spellcheck-textarea-ref.html blur its contents so that we would test the right thing
: Make spellcheck-textarea-ref.html blur its contents so that we would test the...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: :Ehsan Akhgari
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 08:12 PDT by :Ehsan Akhgari
Modified: 2012-05-12 09:04 PDT (History)
3 users (show)
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (2.28 KB, patch)
2012-05-11 08:40 PDT, :Ehsan Akhgari
roc: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2012-05-11 08:12:33 PDT
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/layout/reftests/xul/menulist-shrinkwrap-2.xul | image comparison (==)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-attr.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-nofocus.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-disabled.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-attr-inherit.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-attr-dynamic.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-attr-dynamic-inherit.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-property-dynamic.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-property-dynamic-inherit.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-attr-dynamic-override.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-attr-dynamic-override-inherit.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-property-dynamic-override.html | image comparison (!=)
REFTEST TEST-UNEXPECTED-PASS | http://10.250.48.210:30073/tests/editor/reftests/spellcheck-textarea-property-dynamic-override-inherit.html | image comparison (!=)
Comment 1 :Ehsan Akhgari 2012-05-11 08:18:10 PDT
Actually, this happens because spellcheck-textarea-ref.html focuses the textarea to trigger a spell check, but does not blur it, and the textarea looking different when focused is the reason these tests pass.  We should just fix spellcheck-textarea-ref.html to not do that!
Comment 2 :Ehsan Akhgari 2012-05-11 08:40:43 PDT
Created attachment 623155 [details] [diff] [review]
Patch (v1)
Comment 4 Matt Brubeck (:mbrubeck) 2012-05-12 09:04:03 PDT
https://hg.mozilla.org/mozilla-central/rev/af802c58e1cf

Note You need to log in before you can comment on or make changes to this bug.