Check for Updates always needs 2 tries

RESOLVED FIXED

Status

()

Firefox
Untriaged
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: M ODonnell, Unassigned)

Tracking

15 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120511030513

Steps to reproduce:

Allowed Nightly to update itself.


Actual results:

The first attempt to invoke the "Check For Updates" behavior via the Help->AboutNightly dialog always fails (times out, fails to connect) on the first attempt and always succeeds (connects) on the second try.


Expected results:

One attempt should be enough, assuming network and server are functioning.
Have you got NoScript installed? I see this too, but only when NoScript is enabled.
(Reporter)

Comment 2

5 years ago
Ah.  Indeed, the behavior in question is only observed when NoScript is enabled. Is that CheckForUpdates operation implemented as Javascript?  And although this particular behavior is admittedly not a showstopper problem in itself I wonder if this may be a symptom of more profound interactions between NoScript and Firefox - that would be bad since NoScript is such an important tool...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

5 years ago
It should be fixed by NoScript 2.4.2rc2 from http://noscript.net/getit#devel -- thank you for reporting.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.