Last Comment Bug 754432 - Let Thunderbird have access to ContactService.jsm and ContactDB.jsm.
: Let Thunderbird have access to ContactService.jsm and ContactDB.jsm.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: mozilla15
Assigned To: Mike Conley (:mconley)
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 754390
  Show dependency treegraph
 
Reported: 2012-05-11 13:35 PDT by Mike Conley (:mconley)
Modified: 2012-05-15 06:21 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (827 bytes, patch)
2012-05-11 13:35 PDT, Mike Conley (:mconley)
fabrice: review+
Details | Diff | Splinter Review

Description Mike Conley (:mconley) 2012-05-11 13:35:04 PDT
Created attachment 623278 [details] [diff] [review]
Patch v1

ContactService.jsm and ContactDB.jsm are the fallback storage mechanism for the Contacts API, and are currently only available in b2g builds.

The Thunderbird team has started to make moves to use the Contacts API for storage / retrieval of contacts for a new address book.  One of those moves is to start working on desktop support for the Contacts API.  As part of this effort, we'll want access to the fallback storage mechanism.

The attached patch alters the Makefile for dom/contacts to package ContactService.jsm and ContactDB.jsm for both b2g and mail.
Comment 1 Mike Conley (:mconley) 2012-05-11 13:36:04 PDT
Comment on attachment 623278 [details] [diff] [review]
Patch v1

r?'ing fabrice because he originally r+'d the patch in bug 731855.
Comment 2 Mike Conley (:mconley) 2012-05-11 13:38:07 PDT
So that filter is my way of doing logical OR for Makefiles... let me know if there's another preferred method.
Comment 3 [:fabrice] Fabrice Desré 2012-05-11 15:15:53 PDT
Comment on attachment 623278 [details] [diff] [review]
Patch v1

Review of attachment 623278 [details] [diff] [review]:
-----------------------------------------------------------------

I don't know of any other method either.
Comment 4 Mike Conley (:mconley) 2012-05-14 07:11:10 PDT
Thanks for the fast review, Fabrice.

mozilla-inbound:  https://hg.mozilla.org/integration/mozilla-inbound/rev/de6d19899b89
Comment 5 Matt Brubeck (:mbrubeck) 2012-05-14 14:15:00 PDT
https://hg.mozilla.org/mozilla-central/rev/de6d19899b89
Comment 6 Philip Chee 2012-05-14 21:50:20 PDT
Does this also include SeaMonkey? Or do we need an extra patch in /suite/?
Comment 7 Mike Conley (:mconley) 2012-05-15 06:21:00 PDT
(In reply to Philip Chee from comment #6)
> Does this also include SeaMonkey? Or do we need an extra patch in /suite/?

This patch only took care of Thunderbird, I'm afraid. If suite needs access to ContactService.jsm and ContactDB.jsm, an extra patch will be required here.

Note You need to log in before you can comment on or make changes to this bug.