Some embedded Flash on abcnews.com will not load (plugin object area is blank)

VERIFIED FIXED in Firefox 14

Status

()

Core
JavaScript Engine
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: IU, Assigned: luke)

Tracking

({regression})

14 Branch
mozilla15
regression
Points:
---

Firefox Tracking Flags

(firefox14 verified, firefox15+ verified)

Details

(Whiteboard: [js:p1:fx15], URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Some embedded Flash on abcnews.com will not load (plugin object area is blank)

STR:
Visit the following URL: http://abcnews.go.com/Nightline/mythbusters-kardashian-fact-versus-fairy-tale/story?id=10729219#.T62lo32_4SH

The regression window is:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b1421c3cd5c8&tochange=1664d00a1d24

Caused by either bug 740446 or bug 740259.  Suspect bug 740259.
(Reporter)

Updated

5 years ago
Blocks: 740259
Keywords: regression
status-firefox15: --- → affected
tracking-firefox15: --- → ?
(Assignee)

Comment 1

5 years ago
Yep, definitely bug 740259.  I'll look into it.
Assignee: general → luke
(Assignee)

Comment 2

5 years ago
Created attachment 623736 [details] [diff] [review]
fix

This is funny.  I bisected the problem to a line of JS in flashembed.js:
  var i=document.all
where "i" is an aliased variable.  The bug is that JSOP_SETLOCAL is JOF_DETECTING and JSOP_SETALIASEDVAR is not.

Finally, FF users can find out the answer to that burning question:
  Fact vs. Fairy Tale: Does Kim Kardashian Have Butt Implants?
Attachment #623736 - Flags: review?(bhackett1024)
Attachment #623736 - Flags: review?(bhackett1024) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/984073312d57
Target Milestone: --- → mozilla15
(Assignee)

Comment 4

5 years ago
Comment on attachment 623736 [details] [diff] [review]
fix

[Approval Request Comment]
Regression caused by (bug #): 740259
User impact if declined: broken web pages (such as comment 0)
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): very low
Attachment #623736 - Flags: approval-mozilla-aurora?
tracking-firefox15: ? → +
Whiteboard: [js:p1:fx15]

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/984073312d57
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
Comment on attachment 623736 [details] [diff] [review]
fix

[Triage Comment]
Website breakage, regression in 14, low risk. Approved for Aurora 14.
Attachment #623736 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/c897dadfb74c
status-firefox15: affected → fixed

Updated

5 years ago
No longer blocks: 740259
status-firefox14: --- → fixed
Version: Trunk → 14 Branch

Updated

5 years ago
Blocks: 740259
Verified fixed on FF 14b7 on Win 7, Ubuntu 12.04 and Mac OS X 10.6.
status-firefox14: fixed → verified
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [js:p1:fx15] → [js:p1:fx15][qa+:paul.silaghi]
Flash content is loaded ok. Verified fixed on FF 15b3 on Win 7, Ubuntu 12.04 and Mac OS X 10.6.
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
Whiteboard: [js:p1:fx15][qa+:paul.silaghi] → [js:p1:fx15]

Comment 10

5 years ago
Created attachment 663318 [details]
Test case wmv video failing

Comment 11

5 years ago
Comment on attachment 663318 [details]
Test case wmv video failing

Verified error on Firefox 15 on windows Xp

Object area is blank on loading the page, it takes more than 30 seconds once the video is downloaded to appear.

Is not a matter of the browser waiting the video to download and then showing it after the download is finished
because if you use a video stored on your filesystem (without a server) it takes more time to appear and sometimes 
it doesn't even appear and only selecting the object in firebug on the HTML tab forces the video content to load.

Verified the error with the following three ways to include a WMV video (only one at a time) :
 
           <embed name="video" style="border:1px solid blue" type="application/x-mplayer2" src ="http://res1.windows.microsoft.com/resbox/en/Windows%207/Main/c4e45c98-505e-471d-80c3-a383dea3d647_7.wmv" width="800" height="600" showcontrols="1"></embed>
		
			<object type="video/x-ms-wmv" style="border:1px solid blue" data="http://res1.windows.microsoft.com/resbox/en/Windows%207/Main/c4e45c98-505e-471d-80c3-a383dea3d647_7.wmv" width="800" height="600">
              <param name="src" value="http://res1.windows.microsoft.com/resbox/en/Windows%207/Main/c4e45c98-505e-471d-80c3-a383dea3d647_7.wmv" />
              <param name="controller" value="true" />
              <param name="autostart" value="true" />
            </object>
		
            <object type="application/x-mplayer2" style="border:1px solid blue" width="800" height="600" data="http://res1.windows.microsoft.com/resbox/en/Windows%207/Main/c4e45c98-505e-471d-80c3-a383dea3d647_7.wmv">
                  <param name="pluginurl" value="http://www.microsoft.com/Windows/MediaPlayer/" />
                  <param name="controller" value="true" />
            </object>

Comment 12

5 years ago
Created attachment 663319 [details]
Test case wmv video with workaround

A workaround has been found duplicating the object (with very small dimensions to not interfere on the display), when more than one object is present on the page the first video loads OK and appears instantly on the page and only the last video included takes more time to load.

Comment 13

5 years ago
volatilevol, this bug is fixed and verified. If you think you have discovered a new issue, please file a new bug.
You need to log in before you can comment on or make changes to this bug.