Crashes after changed a language font.

VERIFIED DUPLICATE of bug 68208

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 68208
18 years ago
17 years ago

People

(Reporter: Yuying Long, Assigned: nhottanscp)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 04-05 Linux trunk.
Also reproducible: 03-16 trunk
Not reproducible: N6.01 

After changed a language font then click "OK" button, you will see the crashes.
(Assignee)

Updated

18 years ago
Keywords: crash
Summary: Crashes after changed a language font. → Crashes after changed a language font.
Is this a dup of the crash on changing default font in preferences?  ylong, can
you get a stack trace?
(Reporter)

Comment 2

17 years ago
It was crashes by changing the font in preferences, but I don't know there might 
be one bug about it though.
I sent the crash data to talkback twice, but I don't know why I just couldn't 
find them in cyclone, although I can find my some other crashes on other 
platform there.  I'll ask nhotta help me to get the date from devoloper's tool.
When you get the talkback or other debug info, please compare it to the data in
bug 68208

Updated

17 years ago
QA Contact: andreasb → ylong

Comment 4

17 years ago
here is the stack trace:

(gdb) bt
#0  0x00000019 in ?? ()
#1  0x41591002 in StyleContextImpl::ShareStyleData (this=0x8758e10) at
nsStyleContext.cpp:3858
#2  0x41590689 in StyleContextImpl::RemapStyle (this=0x8758e10,
aPresContext=0x87205c8, aRecurse=1) at nsStyleContext.cpp:3617
#3  0x41592f90 in NS_NewStyleContext (aInstancePtrResult=0xbfffbdbc,
aParentContext=0x866d270, aPseudoTag=0x0, aRules=0x87449c8,
aPresContext=0x87205c8) at nsStyleContext.cpp:4345
#4  0x41594fd4 in StyleSetImpl::GetContext (this=0x85d5be8,
aPresContext=0x87205c8, aParentContext=0x866d270, aPseudoTag=0x0,
aRules=0x87449c8, aForceUnique=0, aUsedRules=@0xbfffbe0c) at nsStyleSet.cpp:838
#5  0x415952e0 in StyleSetImpl::ResolveStyleFor (this=0x85d5be8,
aPresContext=0x87205c8, aContent=0x86e5048, aParentContext=0x866d270,
aForceUnique=0) at nsStyleSet.cpp:922
#6  0x41a8fa4b in nsPresContext::ResolveStyleContextFor (this=0x87205c8,
aContent=0x86e5048, aParentContext=0x866d270, aForceUnique=0,
aResult=0xbfffc088) at nsPresContext.cpp:697
#7  0x419d6ca2 in nsCSSFrameConstructor::ConstructDocElementFrame
(this=0x85c70e8, aPresShell=0x86b5d78, aPresContext=0x87205c8,
aState=@0xbfffc184, aDocElement=0x86e5048, aParentFrame=0x8704cdc,
aParentStyleContext=0x866d270, aNewFrame=@0xbfffc178) at
nsCSSFrameConstructor.cpp:3379
#8  0x419e0b8f in nsCSSFrameConstructor::ReconstructDocElementHierarchy
(this=0x85c70e8, aPresContext=0x87205c8) at nsCSSFrameConstructor.cpp:7295
#9  0x41596152 in StyleSetImpl::ReconstructDocElementHierarchy (this=0x85d5be8,
aPresContext=0x87205c8) at nsStyleSet.cpp:1206
#10 0x4195b64c in PresShell::ReconstructFrames (this=0x86b5d78) at
nsPresShell.cpp:4615
#11 0x41950521 in PresShell::SetPreferenceStyleRules (this=0x86b5d78,
aForceReflow=1) at nsPresShell.cpp:1892
#12 0x41a8e9c8 in nsPresContext::PreferenceChanged (this=0x87205c8,
aPrefName=0x8a344f0 "browser.display.screen_resolution") at
nsPresContext.cpp:447
#13 0x41a8cc3d in PrefChangedCallback (aPrefName=0x8a344f0
"browser.display.screen_resolution", instance_data=0x87205c8) at
nsPresContext.cpp:72
#14 0x40b2cc95 in pref_DoCallback (changed_pref=0x8a344f0
"browser.display.screen_resolution") at prefapi.c:1761
#15 0x40b2bf7e in pref_HashPref (key=0x8a344f0
"browser.display.screen_resolution", value={stringVal = 0x60 <Address 0x60 out
of bounds>, intVal = 96, boolVal = 96}, type=PREF_INT, action=PREF_SETUSER) at
prefapi.c:1366
#16 0x40b2a455 in PREF_SetIntPref (pref_name=0x8a344f0
"browser.display.screen_resolution", value=96) at prefapi.c:565
#17 0x40b30003 in nsPref::SetIntPref (this=0x810fc90, pref=0x8a344f0
"browser.display.screen_resolution", value=96) at nsPref.cpp:823
#18 0x4015e496 in XPTC_InvokeByIndex (that=0x810fc90, methodIndex=17,
paramCount=2, params=0xbfffc638) at xptcinvoke_unixish_x86.cpp:138
#19 0x40b99f57 in nsXPCWrappedNativeClass::CallWrappedMethod (this=0x829f4c8,
cx=0x88835e0, wrapper=0x89dfda8, desc=0x8307a50, callMode=CALL_METHOD, argc=2,
argv=0x8b20f6c, vp=0xbfffc7e0) at xpcwrappednativeclass.cpp:934
#20 0x40b9c6a6 in WrappedNative_CallMethod (cx=0x88835e0, obj=0x892b660, argc=2,
argv=0x8b20f6c, vp=0xbfffc7e0) at xpcwrappednativejsops.cpp:250
#21 0x40226b3d in js_Invoke (cx=0x88835e0, argc=2, flags=0) at jsinterp.c:813
#22 0x40234f39 in js_Interpret (cx=0x88835e0, result=0xbfffd0bc) at
jsinterp.c:2706
#23 0x40226bc0 in js_Invoke (cx=0x88835e0, argc=0, flags=0) at jsinterp.c:830
#24 0x40234f39 in js_Interpret (cx=0x88835e0, result=0xbfffd9cc) at
jsinterp.c:2706
#25 0x40226bc0 in js_Invoke (cx=0x88835e0, argc=1, flags=2) at jsinterp.c:830
#26 0x40226eef in js_InternalInvoke (cx=0x88835e0, obj=0x8929a50,
fval=144591240, flags=0, argc=1, argv=0xbfffdcc0, rval=0xbfffdb84) at
jsinterp.c:902
#27 0x401fae08 in JS_CallFunctionValue (cx=0x88835e0, obj=0x8929a50,
fval=144591240, argc=1, argv=0xbfffdcc0, rval=0xbfffdb84) at jsapi.c:3340
#28 0x405fc8d1 in nsJSContext::CallEventHandler (this=0x8883220,
aTarget=0x8929a50, aHandler=0x89e4988, argc=1, argv=0xbfffdcc0,
aBoolResult=0xbfffdc10, aReverseReturnResult=0) at nsJSEnvironment.cpp:939
#29 0x4065a2aa in nsJSEventListener::HandleEvent (this=0x88de4a0,
aEvent=0x894c83c) at nsJSEventListener.cpp:154
#30 0x41317fb1 in nsEventListenerManager::HandleEventSubType (this=0x82b4a88,
aListenerStruct=0x88e3008, aDOMEvent=0x894c83c, aCurrentTarget=0x88d08b0,
aSubType=8, aPhaseFlags=7) at nsEventListenerManager.cpp:920
#31 0x4131abd8 in nsEventListenerManager::HandleEvent (this=0x82b4a88,
aPresContext=0x889b128, aEvent=0xbfffe814, aDOMEvent=0xbfffe668,
aCurrentTarget=0x88d08b0, aFlags=7, aEventStatus=0xbfffe858) at
nsEventListenerManager.cpp:1848
#32 0x41476ea3 in nsXULElement::HandleDOMEvent (this=0x88d08a8,
aPresContext=0x889b128, aEvent=0xbfffe814, aDOMEvent=0xbfffe668, aFlags=1,
aEventStatus=0xbfffe858) at nsXULElement.cpp:3672
#33 0x4195d065 in PresShell::HandleDOMEventWithTarget (this=0x889b980,
aTargetContent=0x88d08a8, aEvent=0xbfffe814, aStatus=0xbfffe858) at
nsPresShell.cpp:5261
#34 0x41a4e811 in nsButtonBoxFrame::MouseClicked (this=0x89462c0,
aPresContext=0x889b128, aEvent=0xbfffeb00) at nsButtonBoxFrame.cpp:180
#35 0x41a4e263 in nsButtonBoxFrame::HandleEvent (this=0x89462c0,
aPresContext=0x889b128, aEvent=0xbfffeb00, aEventStatus=0xbffff014) at
nsButtonBoxFrame.cpp:124
#36 0x4195ceb0 in PresShell::HandleEventInternal (this=0x889b980,
aEvent=0xbfffeb00, aView=0x0, aFlags=1, aStatus=0xbffff014) at
nsPresShell.cpp:5229
#37 0x4195cbcd in PresShell::HandleEventWithTarget (this=0x889b980,
aEvent=0xbfffeb00, aFrame=0x89462c0, aContent=0x88d08a8, aFlags=1,
aStatus=0xbffff014) at nsPresShell.cpp:5187
#38 0x413255b3 in nsEventStateManager::CheckForAndDispatchClick (this=0x88c0c80,
aPresContext=0x889b128, aEvent=0xbffff164, aStatus=0xbffff014) at
nsEventStateManager.cpp:2291
#39 0x413228c6 in nsEventStateManager::PostHandleEvent (this=0x88c0c80,
aPresContext=0x889b128, aEvent=0xbffff164, aTargetFrame=0x89462c0,
aStatus=0xbffff014, aView=0x889b508) at nsEventStateManager.cpp:1390
#40 0x4195cf11 in PresShell::HandleEventInternal (this=0x889b980,
aEvent=0xbffff164, aView=0x889b508, aFlags=1, aStatus=0xbffff014) at
nsPresShell.cpp:5234
#41 0x4195c8c9 in PresShell::HandleEvent (this=0x889b980, aView=0x889b508,
aEvent=0xbffff164, aEventStatus=0xbffff014, aForceHandle=1,
aHandled=@0xbfffefd4) at nsPresShell.cpp:5141
#42 0x41cc1d1e in nsView::HandleEvent (this=0x889b508, event=0xbffff164,
aEventFlags=28, aStatus=0xbffff014, aForceHandle=1, aHandled=@0xbfffefd4) at
nsView.cpp:364
#43 0x41cce8d6 in nsViewManager::DispatchEvent (this=0x889b3a8,
aEvent=0xbffff164, aStatus=0xbffff014) at nsViewManager.cpp:2018
#44 0x41cc12f0 in HandleEvent (aEvent=0xbffff164) at nsView.cpp:67
#45 0x408480eb in nsWidget::DispatchEvent (this=0x889b570, aEvent=0xbffff164,
aStatus=@0xbffff0d4) at nsWidget.cpp:1471
#46 0x40847cc6 in nsWidget::DispatchWindowEvent (this=0x889b570,
event=0xbffff164) at nsWidget.cpp:1362
#47 0x408481ab in nsWidget::DispatchMouseEvent (this=0x889b570,
aEvent=@0xbffff164) at nsWidget.cpp:1498
#48 0x40849665 in nsWidget::OnButtonReleaseSignal (this=0x889b570,
aGdkButtonEvent=0x8190158) at nsWidget.cpp:2047
#49 0x40850843 in nsWindow::HandleGDKEvent (this=0x889b570, event=0x8190158) at
nsWindow.cpp:1465
#50 0x4083ea30 in dispatch_superwin_event (event=0x8190158, window=0x889b570) at
nsGtkEventHandler.cpp:1022
#51 0x4083e54b in handle_gdk_event (event=0x8190158, data=0x0) at
nsGtkEventHandler.cpp:843
#52 0x409dc333 in gdk_event_dispatch (source_data=0x0, current_time=0xbffff4a0,
user_data=0x0) at gdkevents.c:2129
#53 0x40a07846 in g_main_dispatch (dispatch_time=0xbffff4a0) at gmain.c:656
#54 0x40a07e73 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#55 0x40a0802c in g_main_run (loop=0x8270198) at gmain.c:935
#56 0x4092ba4b in gtk_main () at gtkmain.c:476
#57 0x408323ad in nsAppShell::Run (this=0x80b8da0) at nsAppShell.cpp:360
#58 0x4077b345 in nsAppShellService::Run (this=0x80b66d8) at
nsAppShellService.cpp:407
#59 0x08055159 in main1 (argc=1, argv=0xbffff7e4, nativeApp=0x0) at
nsAppRunner.cpp:1005
#60 0x08055fd1 in main (argc=1, argv=0xbffff7e4) at nsAppRunner.cpp:1300
#61 0x403329cb in __libc_start_main (main=0x8055dbc <main>, argc=1,
argv=0xbffff7e4, init=0x804f904 <_init>, fini=0x8063060 <_fini>,
rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffff7dc) at
../sysdeps/generic/libc-start.c:92

(gdb) 

Comment 5

17 years ago
it crashed at line 3858 ofnsStyleContext.cpp
note: 'this' = 0x19

	
-	3850	  if (bEnableSharing && bSharingSupported) {
 	3851	    // set the CRC
-	3852	    mStyleData->SetCRC32();
 	3853	
-	3854	    NS_ASSERTION(mStyleSet, "Expected to have a style set ref...");
-	3855	    nsIStyleContext *matchingSC = nsnull;
 	3856	
 	3857	    // check if there is a matching context...
-	3858	    result = mStyleSet->FindMatchingContext(this, &matchingSC);
 	3859	    if ((NS_SUCCEEDED(result)) && 
-	3860	        (nsnull != matchingSC)) {
-	3861	      ShareStyleDataFrom(matchingSC);
 	3862	#ifdef NOISY_DEBUG
 	3863	      printf("SC Data Shared :)\n");
 	3864	#endif
-	3865	      NS_IF_RELEASE(matchingSC);
-	3866	    } else {
 	3867	#ifdef NOISY_DEBUG
 	3868	      printf("Unique SC Data - Not Shared :(\n");
 	3869	#endif
 	3870	    }
 	3871	  }
Brian, that stack trace makes this a dup of bug 68208....  
(Assignee)

Comment 7

17 years ago
Thanks Brian.


*** This bug has been marked as a duplicate of 68208 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

17 years ago
Verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.