Fennec stops rendering mobile UPS page (

VERIFIED WORKSFORME

Status

()

Firefox for Android
General
VERIFIED WORKSFORME
6 years ago
2 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
To reproduce:
1. Go to https://m.ups.com/mobile/ratetnthome?loc=en_US
2. Try to change the "Ship from" (or "Ship to", doesn't matter) country to another country

Results:
After entering a country and tapping on Search you don't get to see the drop-down with the list of countries available. Sometimes you get to see the drop-down, but nothing happens when tapping on "Select" afterwards to select that country. After rotating to the mobile to switch to landscape mode (or to portrait mode) it actually renders the new page.

This happens with a current mozilla-central trunk build and an Aurora build. I searched for existing bugs on this, but could not find anything.

Tested on Galaxy S2, Android 4.0.3
(Reporter)

Comment 1

6 years ago
Actually it looks like you cannot reproduce this problem that easily. Just tried again, now I cannot reproduce the problem everytime anymore. But it seems to be easier to reproduce this on a mozilla-central nightly build.
(Reporter)

Comment 2

6 years ago
What seems to be related/required to reproduce the bug: You have to turn your mobile to switch from portrait to landscape mode (or vice versa) after entering a country (maybe after tapping on "Search"). This seems to "trigger" the bug in some way. I have no exact steps to reproduce this yet.
Summary: Fennec stops rendering mobile UPS page → Fennec stops rendering mobile UPS page (
I am unable to reproduce the bug on the latest nightly (2012-06-10)
Samsung Galaxy SII (2.3.4)
Galaxy Nexus (4.0.2)

Frank, are you still seeing this issue on the latest builds?
(Reporter)

Comment 4

6 years ago
I can still reproduce with a current mozilla-central nightly build. I used the steps from Comment 2, I turned my mobile from portrait to landscape after tapping on Search (and getting the search results). When I then select the country and tap on "Select" see Comment 0. Bug 763107 might be related to this (another bug where I see a webpage not updating).
(Reporter)

Comment 5

6 years ago
Created attachment 631901 [details]
ADB log

Not sure if this will help, but I created a ADB log. The log starts with me turning the device from portrait to landscape after tapping on Search and waiting for the results. At 17:11:41 I turned the device again back from landscape to portrait and after that it rendered the page again.

Comment 6

6 years ago
I can reproduce in Galaxy S2 using Android 2.3.4 and Nightly 20120618. 
I think it's worth to fix because UPS in an international service.
tracking-fennec: --- → ?
We probably do need to break down the page.  I believe I saw this on the Nexus S running gingerbread with the Nightly 20120618 as well.  It only happened rarely though.  I tried a number of times on the Nexus S and Galaxy S II...
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

6 years ago
BTW: Sometimes I can reproduce this bug without rotating the device. I'm not sure why and when this bug happens (and when not).
(Reporter)

Comment 9

6 years ago
This bug is quite annoying, it also seems to occur on other pages (for example bahn.de). Not sure why I hit this bug so often and others don't.
We just fixed a bunch of invalidation bugs, qawanted to retest
Keywords: qawanted
I tried to check but I came across a variant of bug https://bugzilla.mozilla.org/show_bug.cgi?id=759857. The cursor always goes back to the left of the last typed letter, so the words get written backwards: "anitnegrA" instead of "Argentina", so I get an "Enter a valid country name of course-

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

6 years ago
I cannot reproduce this bug anymore, tested with yesterday's nightly (so without the fix for Bug 787060).
I cannot reproduce it either on the latest Nightly. Closing bug as verified WFM.

--
Firefox 18.0a1 (2012-09-14)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.