Last Comment Bug 754696 - Make nsSVGOuterSVGFrame call UpdateBounds on its children before calling FinishAndStoreOverflow
: Make nsSVGOuterSVGFrame call UpdateBounds on its children before calling Fini...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
:
Mentors:
Depends on:
Blocks: 734082
  Show dependency treegraph
 
Reported: 2012-05-13 12:30 PDT by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2012-05-16 19:33 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.09 KB, patch)
2012-05-14 01:07 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-13 12:30:16 PDT
nsSVGOuterSVGFrame should call UpdateBounds on its children before it calls FinishAndStoreOverflow. This doesn't currently matter since nsSVGOuterSVGFrame childrens' bounds are not currently used to calculate the nsSVGOuterSVGFrame's overflow rects, but obviously once they are we need to calculate the children's bounds first.
Comment 1 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-14 01:07:15 PDT
Created attachment 623603 [details] [diff] [review]
patch
Comment 2 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-05-16 03:29:37 PDT
Pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/8dc6d1111442
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-05-16 19:33:00 PDT
https://hg.mozilla.org/mozilla-central/rev/8dc6d1111442

Note You need to log in before you can comment on or make changes to this bug.