Last Comment Bug 754751 - [Azure] Fix GetClippedGeometry to work with rectangular clips
: [Azure] Fix GetClippedGeometry to work with rectangular clips
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Bas Schouten (:bas.schouten)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 19:07 PDT by Bas Schouten (:bas.schouten)
Modified: 2012-05-16 03:54 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix GetClippedGeometry (2.13 KB, patch)
2012-05-13 19:07 PDT, Bas Schouten (:bas.schouten)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Bas Schouten (:bas.schouten) 2012-05-13 19:07:31 PDT
Created attachment 623550 [details] [diff] [review]
Fix GetClippedGeometry

After rectangular clips were introduced GetClippedGeometry was never updated to deal with them. Since Canvas doesn't use rectangular clips that's no problem for production. But it is with the Azure-Thebes wrapper.
Comment 1 Bas Schouten (:bas.schouten) 2012-05-15 08:03:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/00927678a3c4
Comment 2 Ed Morley [:emorley] 2012-05-16 03:54:12 PDT
Please can you set the target milestone when landing on inbound. Thank you :-)

https://hg.mozilla.org/mozilla-central/rev/00927678a3c4

Note You need to log in before you can comment on or make changes to this bug.