Crash if reply to an email and change the 'To' to a 'CC'.

VERIFIED WORKSFORME

Status

MailNews Core
Composition
--
critical
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Richard Kinder, Assigned: varada)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-23.uid32 i686; en-US; 0.8.1)
Gecko/20010327
BuildID:    2001032716

Reply to an email sent from a single user, click on the 'To:' field, change it
to 'CC:' and watch moz crash...

Reproducible: Always
Steps to Reproduce:
1.Open a mail window
2.Reply to an email (not reply all)
3.Click on the 'To:' button to the left of the email address, change it to 'CC:'
4.Crash and burn!

Actual Results:  Crash

Expected Results:  Change the 'To:' to a 'CC:' and not crash.

Comment 1

17 years ago
Reporter do you have the stack trace from the crash?
Severity: normal → critical
Keywords: crash

Updated

17 years ago
QA Contact: esther → sheelar

Comment 2

17 years ago
commercial buildid:  2001-04-11-05 on linux. I did not crash following the steps
below.  I was replying to a plain text message in plain text from an html
composer. Reporter, do you still see this problem on recent builds?
(Reporter)

Comment 3

17 years ago
OK, downloaded 2001041108 and the problem is still present.

The stack trace is below.

(gdb) backtrace
#0  0x0 in ?? ()
#1  0x40becfae in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#2  0x40bf00fe in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#3  0x40cbd24e in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#4  0x40cbd353 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#5  0x40cbd353 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#6  0x40cbd353 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#7  0x40f33ab5 in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#8  0x40f35279 in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#9  0x40f33cab in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#10 0x40fb8448 in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#11 0x40f888b4 in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#12 0x40d5c262 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#13 0x40f34027 in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#14 0x40cceb3f in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#15 0x40cba3ac in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#16 0x40cb67c3 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#17 0x40e6a4a8 in NS_NewScriptNamedNodeMap () from /tmp/mozilla/libjsdom.so
#18 0x40133cf5 in js_Invoke () from /tmp/mozilla/libmozjs.so
#19 0x4013b0d2 in js_Interpret () from /tmp/mozilla/libmozjs.so
#20 0x40133d40 in js_Invoke () from /tmp/mozilla/libmozjs.so
#21 0x40133f3c in js_InternalInvoke () from /tmp/mozilla/libmozjs.so
#22 0x40118d2f in JS_CallFunctionValue () from /tmp/mozilla/libmozjs.so
---Type <return> to continue, or q <return> to quit---
#23 0x40e38530 in nsJSContext::CallEventHandler ()
   from /tmp/mozilla/libjsdom.so
#24 0x40e6d9c6 in nsJSEventListener::HandleEvent ()
   from /tmp/mozilla/libjsdom.so
#25 0x40be411f in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#26 0x40be46fc in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#27 0x40cbd469 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#28 0x40cbd5c0 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#29 0x40f34b37 in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#30 0x40f34a40 in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#31 0x40beb4d3 in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#32 0x40be9d7c in NSGetModule () from /tmp/mozilla/components/libgkcontent.so
#33 0x40f34c0e in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#34 0x40f349cc in NSGetModule () from /tmp/mozilla/components/libgklayout.so
#35 0x40b3b62a in NSGetModule () from /tmp/mozilla/components/libgkview.so
#36 0x40b44c2e in NSGetModule () from /tmp/mozilla/components/libgkview.so
#37 0x40b3afbd in NSGetModule () from /tmp/mozilla/components/libgkview.so
#38 0x40b6db5a in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
#39 0x40b6da85 in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
#40 0x40b6dbe0 in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
#41 0x40b6e85f in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
#42 0x40b7240f in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
#43 0x40b68917 in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
---Type <return> to continue, or q <return> to quit---
#44 0x40b6866c in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
#45 0x405acadf in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#46 0x405da943 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#47 0x405daf29 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#48 0x405db0dc in g_main_run () from /usr/lib/libglib-1.2.so.0
#49 0x404f5043 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#50 0x40b60b3c in NSGetModule () from /tmp/mozilla/components/libwidget_gtk.so
#51 0x411cfdba in NSGetModule () from /tmp/mozilla/components/libnsappshell.so
#52 0x804d4f4 in StringAllocator_char ()
#53 0x804dd85 in StringAllocator_char ()
#54 0x401f5b5c in __libc_start_main (
    main=0x804dc58 <StringAllocator_char(void)+13124>, argc=1, 
    ubp_av=0xbffff754, init=0x804a334 <_init>, fini=0x804f720 <_fini>, 
    rtld_fini=0x4000d634 <_dl_fini>, stack_end=0xbffff74c)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 
can you get some symbols in there?

use "shar" in gdb to load the .so 

example:

(gdb) shar *layout*.so
(Reporter)

Comment 5

17 years ago
'shar' tells me all the symbols are already loaded...where to from here?
if you are running and optimized build, you can get symbols.  (you'd have to use 
talkback)

but looking at the stack it resembes a bug that laurel just logged on me, that I 
claimed is a dup of a bug hyatt might have a dup of.

Comment 7

17 years ago
changing status to new. Laurel do you know the bug number?
Status: UNCONFIRMED → NEW
Ever confirmed: true
compose -> ducarroz
Assignee: sspitzer → ducarroz
Component: Mail Window Front End → Composition

Comment 9

17 years ago
I'm pretty sure this was a dup also.  Sheela, if you can't reproduce this, can
you mark it WORKSFORME? Or r_kinder, could you say if you still see this bug?
(Reporter)

Comment 10

17 years ago
Don't see this in 0.9.0 or the latest nightly build (Mozilla 0.9+
Mozilla/5.0 (X11; U; Linux 2.2.16-23.uid32 i686; en-US; rv:0.9+) Gecko/20010522)

It is, however, present in the default Gnome 1.4 installation.
reassign to varada
Assignee: ducarroz → varada

Comment 12

17 years ago
buildid: 2001052208 linux RH 6.2, gnome-1.0.55.  I cannot reproduce the crash.  
However this seems to be only occurring on Gnome 1.4 version which I don't have 
on my linux machine. 
hi richard. what flavor and version of linux are you running?
On my system, which is RedHat 7.0 (2.2.16-22smp) using Ximian Gnome version
1.4.0.1, I don't experience a crash with build 2001052908.

Comment 15

17 years ago
buildid:  2001053108 Red hat linux release 6.2.OS system release: 2.2.14-5.0smp 
using Gnome version 1.0.55
I am not able to reproduce this crash. Marking this worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 16

17 years ago
verifying as worksforme
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.