Last Comment Bug 754866 - make mozilla.widget.disable-native-theme export shared bool across widgets
: make mozilla.widget.disable-native-theme export shared bool across widgets
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: mozilla15
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 08:38 PDT by Oleg Romashin (:romaxa)
Modified: 2012-05-16 03:55 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Share disable native theme pref across nsWindow implementations (5.92 KB, patch)
2012-05-14 08:55 PDT, Oleg Romashin (:romaxa)
roc: review+
Details | Diff | Review

Description Oleg Romashin (:romaxa) 2012-05-14 08:38:11 PDT
Tried to use mozilla.widget.disable-native-theme in OMTC embedding, bug 746800, and because I use separate embedding nsIWindow implementation, I got lost mozilla.widget.disable-native-theme checks and gDisableNativeTheme bool variable initialized.

I think it make sense to cache mozilla.widget.disable-native-theme pref nsBaseWidget
and use it in NativeTheme ctor's
Comment 1 Oleg Romashin (:romaxa) 2012-05-14 08:55:13 PDT
Created attachment 623690 [details] [diff] [review]
Share disable native theme pref across nsWindow implementations
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-05-15 06:05:14 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e1fcace4621d
Comment 3 Ed Morley [:emorley] 2012-05-16 03:55:19 PDT
https://hg.mozilla.org/mozilla-central/rev/e1fcace4621d

Note You need to log in before you can comment on or make changes to this bug.