Javascript issues with window.opener caused by interaction between Firefox and JRE 1.6.0_31+ applets that redirect

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
6 years ago
a year ago

People

(Reporter: Kelly, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 623695 [details]
Sample applet / html / and javascript to recreate the issue

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120313130407

Steps to reproduce:

1) browser window uses window.open to open a popup which contains applet
2) Applet redirects to a url in the popup window
3) landing page of redirect tries to reference parent window via "window.opener"


Actual results:

window.opener points at "self" instead of parent (it points at the landing page of popup window).


Expected results:

It should continue to point at parent window.
(Reporter)

Comment 1

6 years ago
I could not find another bug ticket created for this.  The original poster of http://support.mozilla.org/en-US/questions/924938 sounds exactly like the problem, but the ticket refered to does not.
(Reporter)

Updated

6 years ago
OS: Linux → Windows 7
(Reporter)

Comment 2

6 years ago
I've recreated this problem on windows on more than one machine.  The one machine I've tried running linux version of firefox didn't seem to have problem, but as this is an interaction between java and firefox, I'm unsure regarding the JRE between the different OS's.  

I originally thought this might be a bug in JRE, but other browsers we've tried still work as we expect them to.  It was just since the update to 11 and now 12 if Firefox that its started not working.

Updated

6 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
QA Contact: untriaged → plugins
Kelly, would you be willing to narrow down which nightly the problem first appeared in?
(Reporter)

Comment 4

6 years ago
I'll see what I can do.
(Reporter)

Comment 5

6 years ago
Ok.. while using 1.6.0_31-b05, I tried various early versions of firefox all the way back to 3.6.28, and had the same problem.  This leads me to believe it is not particular to FF11. 

I then tried earlier versions of java and discovered that between the update from jre-6u29 to jre-6u30 the problem started occuring with firefox (in general).  Version 29 it did not. However, I have tested with IE9 and Safari (for windows) and it WORKS for them.

While I do realize this means the update of java broke this functionality, somehow other browsers are still working.  Could IE and Safari be doing something different that JRE is coding for?

Thank you for your time.
Gah.  That makes it pretty hard to debug what's actually going on, especially since I haven't been able to reproduce this (on Mac) so far.

Josh, do we have someone who can take a look at this on Windows?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Javascript issues with window.opener caused by interaction between Firefox 11+ and JRE 1.6.0_31+ applets that redirect → Javascript issues with window.opener caused by interaction between Firefox and JRE 1.6.0_31+ applets that redirect
Version: 11 Branch → Trunk
(Reporter)

Comment 7

6 years ago
My coworker was able to repro on mac, but only after applying updates to lion.  (I assume this caused the JRE to be updated, but will have to get back to you on that).
(Reporter)

Comment 8

6 years ago
The mac system is on version 10.7.4 of lion.  java version is showing 1.6.31
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.