Last Comment Bug 755045 - Fix build warnings under layout/
: Fix build warnings under layout/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 681192
  Show dependency treegraph
 
Reported: 2012-05-14 14:32 PDT by Josh Matthews [:jdm] (on vacation until Dec 5)
Modified: 2012-07-24 06:34 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
<required> (1.83 KB, patch)
2012-05-14 14:32 PDT, Josh Matthews [:jdm] (on vacation until Dec 5)
no flags Details | Diff | Splinter Review
Fix signed/unsigned warning and correct shadowed method that wasn't updated aong with with its parent class. (2.07 KB, patch)
2012-05-14 14:45 PDT, Josh Matthews [:jdm] (on vacation until Dec 5)
roc: review+
Details | Diff | Splinter Review

Description Josh Matthews [:jdm] (on vacation until Dec 5) 2012-05-14 14:32:12 PDT

    
Comment 1 Josh Matthews [:jdm] (on vacation until Dec 5) 2012-05-14 14:32:15 PDT
Created attachment 623819 [details] [diff] [review]
<required>
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-14 14:36:41 PDT
Comment on attachment 623819 [details] [diff] [review]
<required>

Review of attachment 623819 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/generic/nsHTMLCanvasFrame.cpp
@@ +85,3 @@
>    virtual nsRegion GetOpaqueRegion(nsDisplayListBuilder* aBuilder,
>                                     bool* aSnap,
>                                     bool* aForceTransparentSurface) {

Ah, this is actually a bug!!! The signature changed recently (bug 681192) and I forgot to fix this method! Can you remove the aForceTransparentSurface parameter please?
Comment 3 Josh Matthews [:jdm] (on vacation until Dec 5) 2012-05-14 14:45:37 PDT
Created attachment 623830 [details] [diff] [review]
Fix signed/unsigned warning and correct shadowed method that wasn't updated aong with with its parent class.
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-14 14:47:34 PDT
Comment on attachment 623830 [details] [diff] [review]
Fix signed/unsigned warning and correct shadowed method that wasn't updated aong with with its parent class.

Review of attachment 623830 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/generic/nsHTMLCanvasFrame.cpp
@@ +85,1 @@
>      *aForceTransparentSurface = false;

Take this out or it won't build
Comment 5 Jonathan Watt [:jwatt] 2012-07-24 06:34:27 PDT
Looks like the FrameLayerBuilder issue was fixed in bug 754488 and the nsHTMLCanvasFrame issue was fixed in bug 763451.

Note You need to log in before you can comment on or make changes to this bug.