add option to download multiple addons from an hg repo

RESOLVED DUPLICATE of bug 759396

Status

Release Engineering
General Automation
P4
enhancement
RESOLVED DUPLICATE of bug 759396
6 years ago
4 years ago

People

(Reporter: Jeff Hammel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tests])

(Reporter)

Description

6 years ago
Currently jetperf installs addons from directories via the --addon switch: http://hg.mozilla.org/build/mozharness/file/261f3bca84ea/scripts/jetperf.py#l37

For production and other use, we will want to install addons from a mercurial repo.  Usually this one: 

http://hg.mozilla.org/projects/addon-sdk-jetperf-tests/rev/d7e90684309c

An additional switch should give an option to do so.

Comment 1

6 years ago
In production, we'll probably have a list of repos to check out like this:

http://hg.mozilla.org/build/mozharness/file/261f3bca84ea/configs/multi_locale/mozilla-aurora_android.json#l8
Duplicate of this bug: 755079

Updated

6 years ago
Severity: normal → enhancement
Priority: -- → P4
Whiteboard: [tests]
(Reporter)

Comment 3

6 years ago
This has actually been done for awhile
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 759396
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.