Closed Bug 755094 Opened 8 years ago Closed 7 years ago

click-to-play: Embedded YouTube video player's play button does not respond when Flash plugin is first activated

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 751809

People

(Reporter: cpeterson, Unassigned)

References

()

Details

STR:
1. In about:config, set plugins.click_to_play=true
2. Load http://youtube-global.blogspot.com/
3. Click on one of the embedded YouTube videos to activate the Flash plugin.
4. WITHOUT MOVING THE MOUSE *OUTSIDE* THE BOUNDS OF THE VIDEO PLAYER, click the embedded YouTube video's play button.

AR:
The play button highlights on mouse rollover, but the video will not play. For the play button to respond, you must move the mouse OUTSIDE the bounds of the video player and then back to the play button.

ER:
The video should play with just one click after the Flash plugin is activated.

This may be a bug in YouTube's Flash video player. The YouTube video player is presumably anticipating some mouse event that is only generated when the mouse enters the Flash video after the plugin is activated.
I can reproduce this on Mac OS X Lion. And it affects Dailymotion as well.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 751809
You need to log in before you can comment on or make changes to this bug.