Last Comment Bug 755172 - Add MOZ_FINAL to a bunch idb classes
: Add MOZ_FINAL to a bunch idb classes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
: 716728 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 20:25 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-05-15 06:29 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add MOZ_FINAL to a bunch idb classes (8.77 KB, patch)
2012-05-14 20:25 PDT, Jeff Muizelaar [:jrmuizel]
khuey: review+
Details | Diff | Review

Description Jeff Muizelaar [:jrmuizel] 2012-05-14 20:25:20 PDT
Created attachment 623926 [details] [diff] [review]
Add MOZ_FINAL to a bunch idb classes
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-05-14 20:25:34 PDT
*** Bug 716728 has been marked as a duplicate of this bug. ***
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2012-05-14 20:51:52 PDT
Comment on attachment 623926 [details] [diff] [review]
Add MOZ_FINAL to a bunch idb classes

Review of attachment 623926 [details] [diff] [review]:
-----------------------------------------------------------------

::: mfbt/double-conversion/strtod.cc
@@ +519,4 @@
>  
>    // If the guess doesn't lie near a single-precision boundary we can simply
>    // return its float-value.
> +  if (f1 == f4) {

http://www.youtube.com/watch?v=A9mZZfVJNQ0
Comment 3 Ed Morley [:emorley] 2012-05-15 06:29:04 PDT
https://hg.mozilla.org/mozilla-central/rev/9a50d404f14b

Note You need to log in before you can comment on or make changes to this bug.