Closed Bug 755195 Opened 8 years ago Closed 2 years ago

Bookmarks icon not updated until the link is visited again

Categories

(Firefox :: Bookmarks & History, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: srinath, Unassigned)

Details

Attachments

(1 file)

Attached image GenericIcon.JPG
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

1. Launch Firefox
2. Go to Google.com
3. Bookmark the page using 'Ctrl + D' (you can bookmark it to the toolbar or any of the bookmark folders)
4. Click on the bookmark which you just made


Actual results:

At step 3, Notice the icon for the bookmark. A generic icon (a dashed rounded quadrilateral box appears as the icon)

After step 4, the favicon for the site is updated.


Expected results:

The icon should be updated at step 3 itself without having to re-visit the site.
Component: Untriaged → Bookmarks & History
QA Contact: untriaged → bookmarks
Confirming this in Windows 7. When I first add a bookmark, it doesn't add the favicon, even if the website is currently open in Firefox. I have to click the bookmark in order to update the favicon.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Version: 12 Branch → Trunk
Cannot reproduce.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.