Last Comment Bug 755277 - Build bustage (MSVC10, pymake): Target 'pixman-mmx.obj' has multiple rules with commands | Target 'transform-sse2.obj' has multiple rules with commands
: Build bustage (MSVC10, pymake): Target 'pixman-mmx.obj' has multiple rules wi...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All Windows 7
: -- blocker (vote)
: mozilla15
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks: 748001
  Show dependency treegraph
 
Reported: 2012-05-15 07:06 PDT by Honza Bambas (:mayhemer)
Modified: 2012-05-15 10:02 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid duplicate rules after bug 748001 (2.33 KB, patch)
2012-05-15 08:42 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Honza Bambas (:mayhemer) 2012-05-15 07:06:44 PDT
when building gfx, clobber, up to this date repo.

$mozilla-central/_obj: pymake -C gfx

........

pixman-utils.c
c:\Mozilla\src\mozilla-central\config\rules.mk:1116:0$ c:/Mozilla/mozilla-build/python/python2.7.exe -O c:/Mozilla/src/mozilla-central/build/cl.py cl -Fopixma
n-utils.obj -c  -DPIXMAN_NO_TLS -DUSE_MMX -DUSE_SSE -DUSE_SSE2 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL
_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -Ic:/Mozilla/src/mozilla-central/gfx/cairo/libpixman/src -Ic:/Mozilla/src/mozilla-central/gfx/cairo/libp
ixman/src/../../cairo/src -Ic:/Mozilla/src/mozilla-central/gfx/cairo/libpixman/src -I. -I../../../../dist/include -I../../../../dist/include/nsprpub  -Ic:/Moz
illa/src/mozilla-central/_obj-browser-debug/dist/include/nspr -Ic:/Mozilla/src/mozilla-central/_obj-browser-debug/dist/include/nss        -TC -nologo -W3 -Gy
-Fdgenerated.pdb -we4553  -DDEBUG -D_DEBUG -DTRACING -Zi -Oy- -DPACKAGE="mozpixman" -D_USE_MATH_DEFINES -MDd           -FI ../../../../dist/include/mozilla-co
nfig.h -DMOZILLA_CLIENT c:/Mozilla/src/mozilla-central/gfx/cairo/libpixman/src/pixman-utils.c
pixman-utils.c
c:/Mozilla/src/mozilla-central/gfx/cairo/libpixman/src/pixman-utils.c(272) : warning C4244: 'initializing' : conversion from 'const uint64_t' to 'const uint8_
t', possible loss of data
c:/Mozilla/src/mozilla-central/gfx/cairo/libpixman/src/pixman-utils.c(273) : warning C4244: 'initializing' : conversion from 'const uint64_t' to 'const uint8_
t', possible loss of data
c:/Mozilla/src/mozilla-central/gfx/cairo/libpixman/src/pixman-utils.c(274) : warning C4244: 'initializing' : conversion from 'const uint64_t' to 'const uint8_
t', possible loss of data
> Target 'pixman-mmx.obj' has multiple rules with commands.
c:\Mozilla\src\mozilla-central\config\makefiles\target_libs.mk:139:0: command 'c:/Mozilla/mozilla-build/python/python.exe c:/mozilla/src/mozilla-central/build
/pymake/pymake/../make.py -C libpixman/src libs' failed, return code 2
c:\Mozilla\src\mozilla-central\config\makefiles\target_libs.mk:139:0: command 'c:/Mozilla/mozilla-build/python/python.exe c:/mozilla/src/mozilla-central/build
/pymake/pymake/../make.py -C cairo libs' failed, return code 2
c:\Mozilla\src\mozilla-central\config\rules.mk:682:0: command 'c:/Mozilla/mozilla-build/python/python.exe c:/mozilla/src/mozilla-central/build/pymake/pymake/.
./make.py libs' failed, return code 2


I don't see any recent changes.  Going to bisect...
Comment 1 Ed Morley [:emorley] 2012-05-15 08:06:47 PDT
A clobber pymake win32 build using inbound tip (c14773057d57) and MozillaBuild 1.6 is failing for me with:

{
Target 'transform-sse2.obj' has multiple rules with commands.
Target 'transform-sse1.obj' has multiple rules with commands.
<mozqcms.lib.desc>: Found error
<mozqcms.lib.desc>: Found error
<libs>: Found error
d:\srcdirs\inbound\config\makefiles\target_libs.mk:54:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py -C gfx/qcms libs' failed, return code 2
d:\srcdirs\inbound\config\rules.mk:709:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py libs_tier_platform' failed, return code 2
d:\srcdirs\inbound\config\rules.mk:674:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py  tier_platform' failed, return code 2
d:\srcdirs\inbound\client.mk:381:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py -j12 -C d:/obj-inbound' failed, return code 2
d:\srcdirs\inbound\client.mk:181:0: command 'c:/mozilla-build/python/python.exe d:/srcdirs/inbound/build/pymake/pymake/../make.py -f d:/srcdirs/inbound/client.mk realbuild' failed, return code 2
}

Mozconfig:
{
mk_add_options MOZ_OBJDIR=d:/obj-inbound
mk_add_options MOZ_MAKE_FLAGS=-j12
ac_add_options --disable-optimize
ac_add_options --disable-debug-symbols
ac_add_options --disable-angle
}
Comment 2 Ed Morley [:emorley] 2012-05-15 08:07:43 PDT
Sorry meant to add:
MSVC2010
Windows SDK version: 7.0A
Comment 3 Ed Morley [:emorley] 2012-05-15 08:21:25 PDT
Ted thinks maybe bug 748001?
Comment 4 Mike Hommey [:glandium] 2012-05-15 08:28:09 PDT
Ah, I guess GNU make just uses the new one and only warns about the override
Comment 5 Mike Hommey [:glandium] 2012-05-15 08:29:17 PDT
So, I'd say it's a pymake bug, but it actually is good, because it makes these "duplicated" more easily detectable, and allows for some cleanup.
Comment 6 Mike Hommey [:glandium] 2012-05-15 08:34:09 PDT
Confirmed:
/e/builds/moz2_slave/m-cen-w32/build/config/rules.mk:1114: warning: ignoring old commands for target `transform-sse1.obj'
/e/builds/moz2_slave/m-cen-w32/build/config/rules.mk:1114: warning: ignoring old commands for target `transform-sse2.obj'

Found 2 more:
/e/builds/moz2_slave/m-cen-w32/build/config/rules.mk:1114: warning: ignoring old commands for target `pixman-mmx.obj'
/e/builds/moz2_slave/m-cen-w32/build/config/rules.mk:1114: warning: ignoring old commands for target `pixman-sse2.obj'
Comment 7 Mike Hommey [:glandium] 2012-05-15 08:42:20 PDT
Created attachment 624057 [details] [diff] [review]
Avoid duplicate rules after bug 748001
Comment 8 Honza Bambas (:mayhemer) 2012-05-15 08:49:48 PDT
Comment on attachment 624057 [details] [diff] [review]
Avoid duplicate rules after bug 748001

Confirming this fixes the build for me.

Thanks.
Comment 9 Johan C 2012-05-15 09:30:25 PDT
I'm still running into this problem with the above patch applied.
Normal build:
"pymake -f client.mk"

http://pastebin.mozilla.org/1640417

Mozconfig:
{
mk_add_options MOZ_MAKE_FLAGS=-j6
ac_add_options --disable-optimize
}

MSVC9
Windows SDK 7.0
Comment 10 Johan C 2012-05-15 09:41:53 PDT
Ignore the above pastebin, this is the correct "error-log":

http://pastebin.mozilla.org/1640450
Comment 11 Mike Hommey [:glandium] 2012-05-15 10:02:56 PDT
https://hg.mozilla.org/mozilla-central/rev/00c7a320165b

Note You need to log in before you can comment on or make changes to this bug.