Last Comment Bug 755631 - Extraneous Exceptions in Cross Origin Wrappers
: Extraneous Exceptions in Cross Origin Wrappers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Devdatta Akhawe [:devd]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 23:05 PDT by Devdatta Akhawe [:devd]
Modified: 2012-05-26 15:27 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove some of the exceptions (693 bytes, patch)
2012-05-16 10:32 PDT, Devdatta Akhawe [:devd]
mrbkap: review+
Details | Diff | Review

Description Devdatta Akhawe [:devd] 2012-05-15 23:05:54 PDT
The current mozilla-central/js/xpconnect/wrappers/AccessCheck.cpp file's function 'IsPermitted' special cases DOMException and Error objects as permitted for cross origin access. It is not clear if they are necessary; and since they essentially look like exceptions to the same-origin policy, it might make sense to remove these.
Comment 1 Devdatta Akhawe [:devd] 2012-05-16 10:32:18 PDT
Created attachment 624441 [details] [diff] [review]
Remove some of the exceptions
Comment 2 Blake Kaplan (:mrbkap) (please use needinfo!) 2012-05-22 16:02:56 PDT
Comment on attachment 624441 [details] [diff] [review]
Remove some of the exceptions

Thanks!
Comment 3 :Ms2ger 2012-05-23 09:24:24 PDT
Pushed manually...

https://tbpl.mozilla.org/?tree=Try&rev=51c09d99bc77
Comment 4 :Ms2ger 2012-05-25 03:33:12 PDT
Looks good
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-05-26 06:39:51 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ae9977a419c9

Thanks for the patch, dev! One request - for future patches, please follow the directions below so that it contains all the required metadata for checkin. It makes life easier for those checking in on your behalf. Thanks!
https://developer.mozilla.org/en/Creating_a_patch_that_can_be_checked_in
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-05-26 15:27:34 PDT
https://hg.mozilla.org/mozilla-central/rev/ae9977a419c9

Note You need to log in before you can comment on or make changes to this bug.