Last Comment Bug 755663 - other-licenses/snappy/src/snappy-c.h:49: error: comma at end of enumerator list
: other-licenses/snappy/src/snappy-c.h:49: error: comma at end of enumerator list
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: Other OpenBSD
: -- normal (vote)
: mozilla15
Assigned To: Landry Breuil (:gaston)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 03:00 PDT by Landry Breuil (:gaston)
Modified: 2012-05-17 03:17 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove extra comma at end of enum list (920 bytes, patch)
2012-05-16 03:00 PDT, Landry Breuil (:gaston)
Ms2ger: review+
Details | Diff | Splinter Review

Description Landry Breuil (:gaston) 2012-05-16 03:00:22 PDT
Created attachment 624329 [details] [diff] [review]
Remove extra comma at end of enum list

snappy wasn't built previously, dunno what changed recently that made that error surface.
Comment 1 :Ms2ger 2012-05-16 04:30:53 PDT
Could you submit your patch to <http://code.google.com/p/snappy/> first? I think this is currently a straight import, so I'd like to avoid forking...
Comment 2 Landry Breuil (:gaston) 2012-05-16 05:26:05 PDT
http://code.google.com/p/snappy/issues/detail?id=62
Comment 3 :Ms2ger 2012-05-16 05:30:55 PDT
Comment on attachment 624329 [details] [diff] [review]
Remove extra comma at end of enum list

Review of attachment 624329 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks. I'm fine with landing this on m-c before it's fixed upstream, if you keep track of the issue there.
Comment 4 Landry Breuil (:gaston) 2012-05-16 05:38:16 PDT
Looking deeply into that..

in my previous builds, snappy-c.cc wasnt built/compiled, but was passed to expandlibs_gen.py :

/usr/local/bin/python2.7 /var/buildslave-mozilla/mozilla-central-amd64/build/config/pythonpath.py -I../../config /var/buildslave-mozilla/mozilla-central-amd64/build/config/expandlibs_gen.py snappy-c.cc snappy.o snappy-sinksource.o snappy-stubs-internal.o   > libsnappy_s.a.desc

In the failing build, it is, but with g++ instead of gcc (as snappy-c.cc is in CSRCS) So there might be two different issues here. Something changed that triggered snappy-c.cc to be compiled, and without the correct compiler it seems.
Comment 5 Landry Breuil (:gaston) 2012-05-16 05:41:06 PDT
http://buildbot.rhaalovely.net/builders/mozilla-central-amd64/builds/388/steps/build/logs/stdio for the failing build log
http://buildbot.rhaalovely.net/builders/mozilla-central-amd64/builds/386/steps/build/logs/stdio for a non-failing build log (look for snappy-c)

So something changed in the past two days that triggered snappy-c.cc to be built.
Comment 6 Landry Breuil (:gaston) 2012-05-16 05:46:59 PDT
Seems it's now in CPPSRCS, since bug 748001 / https://hg.mozilla.org/mozilla-central/rev/43cc6c43f79c - and that's what triggered the new build failure.
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-05-16 15:22:20 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0f7d47f6b6dd
Comment 8 Ed Morley [:emorley] 2012-05-17 03:17:53 PDT
https://hg.mozilla.org/mozilla-central/rev/0f7d47f6b6dd

Note You need to log in before you can comment on or make changes to this bug.