The default bug view has changed. See this FAQ.

[jsdbg2] Debugger.Environment.prototype.type never returns 'with'

RESOLVED FIXED in mozilla15

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jimb, Assigned: jimb)

Tracking

Trunk
mozilla15
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
According to the spec, the 'type' property of an environment for a 'with' statement is "with". However, the current implementation only ever returns "declarative" or "object"; 'with' statements get the latter.
(Assignee)

Comment 1

5 years ago
Created attachment 624408 [details] [diff] [review]
Debugger.Environment.prototype.with should return "with" for 'with' statements' environments.

Short and sweet.
Assignee: general → jimb
Status: NEW → ASSIGNED
Attachment #624408 - Flags: review?(jorendorff)
Comment on attachment 624408 [details] [diff] [review]
Debugger.Environment.prototype.with should return "with" for 'with' statements' environments.

Sweet. Thanks.
Attachment #624408 - Flags: review?(jorendorff) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e7bd3c9bbb5
Flags: in-testsuite+
Target Milestone: --- → mozilla15
Blocks: 755787
https://hg.mozilla.org/mozilla-central/rev/2e7bd3c9bbb5
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.