Last Comment Bug 755828 - pymake should copy gmake behavior of not rebuilding targets with no commands, even if they're out of date
: pymake should copy gmake behavior of not rebuilding targets with no commands,...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
Mentors:
Depends on:
Blocks: 755691
  Show dependency treegraph
 
Reported: 2012-05-16 11:02 PDT by Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
Modified: 2012-05-28 00:59 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.44 KB, patch)
2012-05-16 11:34 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
ted: review+
Details | Diff | Splinter Review

Description Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-16 11:02:36 PDT
Given:

all: obj

obj: header
	touch obj

header: cpp

cpp:
	touch header
	touch cpp

On the second pass pymake will decide that header is out of date, and rebuild it.  It will then rebuild obj because header was rebuilt, even though header did not change.  Gmake will decide that rebuilding header serves no purpose since it has no rule, and skip it.  It will then not rebuild obj.
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-16 11:34:05 PDT
Created attachment 624466 [details] [diff] [review]
Patch
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-25 12:15:10 PDT
http://hg.mozilla.org/users/bsmedberg_mozilla.com/pymake/rev/7b1a8cd06963
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-05-28 00:59:16 PDT
And migrated to m-c https://hg.mozilla.org/mozilla-central/rev/e5e7f60fe0be

Note You need to log in before you can comment on or make changes to this bug.