Closed Bug 756002 Opened 9 years ago Closed 9 years ago

problem with scroll in all directions when you start scroll verticaly or horizontally

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 755240

People

(Reporter: mangelasakis, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120423122928

Steps to reproduce:

Problem with scroll in all versions of firefox I have tried so far. When you scroll horizontally it does not scroll diagonally or vertically simultaneously. The same happens when you start to scroll vertically, then horizontally does not scroll and also diagonally. The make firefox scroll in all directions, when you begin to make scroll bars. This happens only when you scroll with one finger. I do not know if it happens to other devices. My device is a sony ericsson live with walkman with android 2.3.4 ...
Severity: normal → major
OS: Linux → Android
Hardware: x86_64 → All
If I understand you correctly, you're describe the axis-locking behaviour we implemented, and the behaviour is intentional. It makes for easier scrolling when reading long pages and such. However, others have also found that it is perhaps a little too strict when it comes to locking the axis; this is currently being re-evaluated in bug 755240. Note that if you start scrolling with a diagonal motion, you should not get axis-locked, and will continue to be able to scroll in any direction.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755240
Yes exactly what I mean. Sorry for my English. 

I believe that the axis-locking system is very frustrating to devices with small screen because you have to do high magnification to read something. And for this reason you usually need to scroll in all directions simultaneously. It would be better axis-locking system is turned off by default. I also believe that it is not common to find large pages in length to be as useful a system like the axis-locking. You could also have an option to turn off the system axis-locking. Nevertheless I believe that this axis-locking system is not at all functional and not useful, especially on devices with small screen.
First, this bug is 5 years old, so the change you are complaining about is already ancient.

Second, I'm sorry you feel like we ruined your life. But maybe if you take a few deep breaths and ask nicely somebody will tell you how to change the behaviour so that it is more to your liking. Most changes of this sort have configuration parameters that you can change yourself.
You need to log in before you can comment on or make changes to this bug.