If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox (only mac version) doesn't fire focus/blur events when someone uses mouse to click a checkbox/radio button

RESOLVED INVALID

Status

()

Core
Event Handling
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Amit Saxena, Unassigned)

Tracking

12 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19

Steps to reproduce:

Please note that this problem is only with the Mac Version of Firefox. It works fine on windows and linux (ubuntu).

When a checkbox/radio is clicked with a mouse, the focus event is not fired. If I use <Tab> key to navigate then the focus event is fired. Here is an example:

http://jsfiddle.net/54y69/147/

Click on the checkboxes on different operating systems and notice the difference.


Actual results:

Focus event was not triggered, whereas it should have been. It is triggered in Windows/Linux version.


Expected results:

Focus event should be triggered when clicking a checkbox/radio on Mac version of Firefox.
(Reporter)

Updated

5 years ago
OS: Linux → Mac OS X

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Component: Untriaged → DOM: Events
Product: Firefox → Core
QA Contact: untriaged → events

Comment 1

5 years ago
IIRC this is on purpose, because the behavior is OSX convention.

Comment 2

5 years ago
(I could be wrong. Haven't used OSX for ages.)

Updated

5 years ago
Component: DOM: Events → Event Handling

Comment 3

5 years ago
That's correct behaviour, as buttons are not focused when clicked on Mac.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

5 years ago
It will be great if someone can explain the reasoning behind different behaviour, depending on the Operating system. Why does this happen only on Mac?

For example, chrome behaves the same on all OS in this case. The focus event is not triggered on clicking the checkbox/radio, and is triggered on pressing <TAB> key, but it is uniform across all platforms.

Comment 5

5 years ago
(In reply to Amit Saxena from comment #4)
> It will be great if someone can explain the reasoning behind different
> behaviour, depending on the Operating system. Why does this happen only on
> Mac?

Since the Mac predates both Windows and gtk, it might be more correct to ask why they are different.

In all seriousness though, we try to implement the focus behaviour of the native operating system as best we can. Which means that on Mac, buttons are not focused when clicked.
You need to log in before you can comment on or make changes to this bug.