Can't tab to buttons on dialogs

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: selmer, Assigned: bryner)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
4/11 04 WinNT

Open any dialog with buttons on it such as the prefs dialog.  Use the tab key to
navigate around the dialog.  The OK/Cancel (and presumably any other such)
buttons cannot be reached.  I've seen this on other dialogs as well, so I think
it's a generalized problem.  

Not sure if event handling is the right place to send this, please forward on
appropriately.
(Reporter)

Updated

18 years ago
Keywords: nsCatFood
Magic 8-ball says XPApps.

/be
Assignee: joki → pchen
Component: Event Handling → XP Apps

Comment 2

18 years ago
Your 8-ball needs to be cleaned.  Mine reads "bryner or saari"...

Brian, your last patch made it so the pref panes can finally be reached 
(thankfully), but also so that you can't get to the buttons anymore once you 
focus the pref panes :-)
Assignee: pchen → bryner
Thank you -- anything beats joki, who tends not to notice new bugs, AFAICT.

/be
(Assignee)

Comment 4

18 years ago
This is fixed by my proposed patch for 31809.


*** This bug has been marked as a duplicate of 31809 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

18 years ago
This bug was not fixed by 31809.  I can't tab to the OK/Cancel buttons in the
prefs dialog on the 4/25 04 build.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

18 years ago
I just tested on Linux, and jrgm tested on Windows, and we were able to tab to
all the buttons in the prefs panel (although I had to click on an element to
focus it first).

If this still doesn't work for you, can you be more specific about the steps
involved?
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

18 years ago
OK, it gets to the buttons.  However, the order is strange.  The first tab after
the panel opens goes to the first element in the right frame.  Tabbing through
goes to each element in that frame.

Tabbing once more goes to something invisible.

Tabbing once more goes to the category in the left frame.

Tabbing once more goes to the OK button.  Another tab to the Cancel button.

Is this *really* the expected behavior???  (Is there a separate bug on the tab
order being goofy?)
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.