Emoticons are not displayed on the Facebook chat

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: simona.marcu, Unassigned)

Tracking

13 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0

Emoticons are intermittently displayed when chatting on Facebook. Managed to reproduce this using Firefox 13 beta 4 on clean but also on rich profiles on several machines and OS's (Windows, Ubuntu and Mac)

Reproducible: intermittently 

Steps to reproduce:
1. Log into your Facebook account.
2. Start to chat and while doing this use emoticons as: :) :P :D

Expected results:
The emoticons are properly displayed.

Actual results:
Instead of seeing the emoticon a blank row is displayed. If hover the mouse where the emoticon should be the characters that form it are displayed.
Can you please test other Firefox versions to see if:

A) This is affecting Aurora and Nightly?
B) This is a regression?
Created attachment 625037 [details]
Empty line displayed instead of emoticons

Adding an attachment from a test account. 

I can reproduce this in Nightly: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/15.0 Firefox/15.0a1

But as Simona says, this can't be reproduced reliably. Logged in/out, opened different chats and am yet to find reliable STRs. Spotted the issue after about 10-15 minutes of trying to reproduce.
 
The issue seems to also occur in Chrome and IE as seems to have been reported in Facebook Help: http://www.facebook.com/help/community/question/?id=2189915

That said, this seems to rather be a Facebook issue than a Firefox regression.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #1)
> Can you please test other Firefox versions to see if:
> B) This is a regression?

Given the lack of reliable STRs, it's hard to actually verify if this occurs for sure on older Firefox versions. But I could reproduce this yesterday with a 10.0.2 ESR.
(In reply to Virgil Dicu [:virgil] [QA] from comment #3)
> Given the lack of reliable STRs, it's hard to actually verify if this occurs
> for sure on older Firefox versions. But I could reproduce this yesterday
> with a 10.0.2 ESR.

One could assume that this will also reproduce in Firefox 10 since 10.0.2esr is based off Firefox 10. Given this happens in other browsers as well, I'm inclined to believe this to be an issue on Facebook's side. Resolving invalid for now but we can reopen if it's something we can fix.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.