Closed Bug 75613 Opened 22 years ago Closed 22 years ago

The find dialog is modal to the browser but sometimes the focus goes to the parent window.

Categories

(SeaMonkey :: UI Design, defect, P2)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 39841

People

(Reporter: naving, Assigned: bugzilla)

Details

When we bring up the search dialog, sometimes the focus goes to the browser 
window and so in this state we have no option left but close the window, because
the search dialog is modal to the browser window. 

Seen on 2001040904 winNT
changing summary. nominating for mozilla 0.9/0.9.1 because you can't so much 
when you are in this state, except close the window.
Severity: normal → major
Priority: -- → P2
Summary: The search dialog should be modal to the browser but in some case it is just the opposite. → The search dialog is modal to the browser but sometimes the focus goes to the parent window.
i thought that search dialogs weren't supposed to be modal. [i can never 
remember what they are supposed to be]
I don't remember exactly whose dialog this is so I'm just sending it over to the proper
component and I'm sure sairuh will make it right. btw Search -does not equal- Find.
Assignee: matt → blakeross
Component: Search → XP Apps: GUI Features
QA Contact: claudius → sairuh
Summary: The search dialog is modal to the browser but sometimes the focus goes to the parent window. → The find dialog is modal to the browser but sometimes the focus goes to the parent window.
probably a duplicate of bug 39841; itself probably an effect of bug 41813.
dupping...

*** This bug has been marked as a duplicate of 39841 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.