Last Comment Bug 756167 - make-makefile test failure if the source path contains perl regexp metacharacters
: make-makefile test failure if the source path contains perl regexp metacharac...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: Chris Coulson
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 11:14 PDT by Chris Coulson
Modified: 2012-05-18 13:21 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix make-makefile test failure when the source path contains perl regexp metacharacters (1.20 KB, patch)
2012-05-17 11:14 PDT, Chris Coulson
coop: review+
Details | Diff | Splinter Review

Description Chris Coulson 2012-05-17 11:14:07 PDT
Created attachment 624803 [details] [diff] [review]
Fix make-makefile test failure when the source path contains perl regexp metacharacters

We get this test failure when running make check in Ubuntu:

/usr/bin/perl /build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/runtest /build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/make-makefile.tpl
/build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/make-makefile.tpl .. ok
All tests successful.
Files=1, Tests=4,  1 wallclock secs ( 0.04 usr  0.00 sys +  0.33 cusr  0.08 csys =  0.45 CPU)
Result: PASS
/usr/bin/perl /build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/runtest /build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/makemakefile.tpm
# Test 6 got: "0" (/build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/makemakefile.tpm at line 123)
#   Expected: "1" (Invalid topdir path)
#  /build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/makemakefile.tpm line 123 is:     ok($FindBin::RealBin =~ m%$path/% ? 1 : 0, 1, 'Invalid topdir path');
/build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/makemakefile.tpm .. 
Failed 1/36 subtests 

Test Summary Report
-------------------
/build/buildd/firefox-12.0+build1/build-tree/mozilla/build/autoconf/test/makemakefile.tpm (Wstat: 0 Tests: 36 Failed: 1)
  Failed test:  6
Files=1, Tests=36,  0 wallclock secs ( 0.06 usr  0.00 sys +  0.08 cusr  0.01 csys =  0.15 CPU)
Result: FAIL
Failed 1/1 test programs. 1/36 subtests failed.
make[3]: *** [.ts/makemakefile.tpm] Error 255
make[3]: Leaving directory `/build/buildd/firefox-12.0+build1/build-tree/mozilla/obj-x86_64-linux-gnu/build/autoconf/test'
make[2]: *** [check] Error 2
make[2]: Leaving directory `/build/buildd/firefox-12.0+build1/build-tree/mozilla/obj-x86_64-linux-gnu/build'
make[1]: *** [check] Error 2

This is because the path contains a perl regexp metacharacter ('+'), and this is not correctly quoted in the test
Comment 1 Ryan VanderMeulen [:RyanVM] 2012-05-17 16:38:28 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/527400dc53a8
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-05-18 13:21:11 PDT
https://hg.mozilla.org/mozilla-central/rev/527400dc53a8

Note You need to log in before you can comment on or make changes to this bug.