Last Comment Bug 756251 - Pass extendedAttributes to CGCallGenerator
: Pass extendedAttributes to CGCallGenerator
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Peter Van der Beken [:peterv]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 13:35 PDT by Peter Van der Beken [:peterv]
Modified: 2012-05-23 05:19 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (15.43 KB, patch)
2012-05-17 13:35 PDT, Peter Van der Beken [:peterv]
bzbarsky: review+
Details | Diff | Splinter Review

Description Peter Van der Beken [:peterv] 2012-05-17 13:35:50 PDT
Created attachment 624867 [details] [diff] [review]
v1

I'd like to use extendedAttributes in CGCallGenerator. We already pass resultAlreadyAddRefed into it, but that's calculated from extendedAttributes so I replaced the resultAlreadyAddRefed argument with extendedAttributes and calculate resultAlreadyAddRefed from it in CGCallGenerator.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-05-17 22:25:35 PDT
Comment on attachment 624867 [details] [diff] [review]
v1

r=me.  I'd been kinda trying to keep PerSignatureCall not caring about whether it's a getter/setter/method, but I agree this ends up cleaner since we don't have to pass the extendedAttributes around.
Comment 2 Peter Van der Beken [:peterv] 2012-05-22 14:32:38 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f071e6f4d3b0
Comment 3 Ed Morley [:emorley] 2012-05-23 05:19:43 PDT
https://hg.mozilla.org/mozilla-central/rev/f071e6f4d3b0

Note You need to log in before you can comment on or make changes to this bug.