Last Comment Bug 756382 - --enable-xterm-updates with make -s spews blank lines into the console
: --enable-xterm-updates with make -s spews blank lines into the console
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- minor (vote)
: mozilla17
Assigned To: Simon Montagu :smontagu
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 00:37 PDT by Simon Montagu :smontagu
Modified: 2012-08-07 07:33 PDT (History)
3 users (show)
smontagu: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.97 KB, patch)
2012-05-18 00:37 PDT, Simon Montagu :smontagu
ted: review+
Details | Diff | Review

Description Simon Montagu :smontagu 2012-05-18 00:37:30 PDT
Created attachment 625023 [details] [diff] [review]
Patch

This has annoyed me for ages, and I finally found a solution which works for me at least.

I'm not sure whether I need to go on using xterm.str or whether that was just a way to get the binary characters.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-06-07 09:42:27 PDT
Comment on attachment 625023 [details] [diff] [review]
Patch

Review of attachment 625023 [details] [diff] [review]:
-----------------------------------------------------------------

printf isn't really portable, but this is off-by-default anyway, so I'm not sure I care.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-06-07 09:43:00 PDT
I think Neil is the only other person I've ever seen express interest in this.
Comment 3 neil@parkwaycc.co.uk 2012-06-07 13:09:19 PDT
(In reply to Simon Montagu)
> I'm not sure whether I need to go on using xterm.str or whether that was
> just a way to get the binary characters.
The idea was that xterm.str did not end in a newline, the intention being that sed would honour that in its output, so you should hg remove it.
Comment 4 Simon Montagu :smontagu 2012-08-07 01:46:49 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7915a59a1691 (including the hg remove)
Comment 5 Ed Morley [:emorley] 2012-08-07 07:33:17 PDT
https://hg.mozilla.org/mozilla-central/rev/7915a59a1691

Note You need to log in before you can comment on or make changes to this bug.