Last Comment Bug 756397 - Enable FAIL_ON_WARNINGS in content/media
: Enable FAIL_ON_WARNINGS in content/media
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
: Maire Reavy [:mreavy]
Mentors:
Depends on: FAIL_ON_WARNINGS 754643 768570
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2012-05-18 02:00 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2013-02-05 00:32 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (4.99 KB, patch)
2012-07-06 09:05 PDT, :Ms2ger (⌚ UTC+1/+2)
cpearce: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-05-18 02:00:27 PDT
+++ This bug was initially created as a clone of Bug #754643 +++

cc1plus: warnings being treated as errors
In file included from ../../../dist/include/VideoUtils.h:43:0,
                 from ../../../../content/media/ogg/nsOggCodecState.h:55,
                 from ../../../../content/media/ogg/nsOggCodecState.cpp:40:
../../../dist/include/mozilla/CheckedInt.h: In static member function 'static bool mozilla::detail::IsInRangeImpl<T, U, true, true>::run(U) [with T = long long int, U = int]':
../../../dist/include/mozilla/CheckedInt.h:317:36:   instantiated from 'bool mozilla::detail::IsInRange(U) [with T = long long int, U = int]'
../../../dist/include/mozilla/CheckedInt.h:530:45:   instantiated from 'mozilla::CheckedInt<T>::CheckedInt(U) [with U = int, T = long long int]'
../../../../content/media/ogg/nsOggCodecState.cpp:629:9:   instantiated from here
../../../dist/include/mozilla/CheckedInt.h:280:59: error: comparison is always true due to limited range of data type
../../../dist/include/mozilla/CheckedInt.h:280:59: error: comparison is always true due to limited range of data type
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2012-07-06 09:05:31 PDT
Created attachment 639696 [details] [diff] [review]
Patch v1
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-07-18 06:12:54 PDT
https://hg.mozilla.org/mozilla-central/rev/f060a6883f1f
Comment 3 Daniel Holbert [:dholbert] 2013-02-04 13:54:10 PST
MFBT isn't the right component for this -- should've been "Video/Audio", presumably.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2013-02-05 00:32:22 PST
(In reply to Daniel Holbert [:dholbert] from comment #3)
> MFBT isn't the right component for this -- should've been "Video/Audio",
> presumably.

FWIW, it was in MFBT because the only warnings were caused by CheckedInt.h at the time.

Note You need to log in before you can comment on or make changes to this bug.