Last Comment Bug 756405 - non-scaling-stroke-02.svg fails on Android
: non-scaling-stroke-02.svg fails on Android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: Other Android
: -- normal (vote)
: mozilla15
Assigned To: Robert Longson
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 03:26 PDT by Robert Longson
Modified: 2012-05-20 23:39 PDT (History)
1 user (show)
longsonr: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.42 KB, patch)
2012-05-20 00:38 PDT, Robert Longson
jwatt: review+
Details | Diff | Splinter Review

Description Robert Longson 2012-05-18 03:26:09 PDT

    
Comment 1 Robert Longson 2012-05-20 00:38:01 PDT
Created attachment 625466 [details] [diff] [review]
patch

It's a permanent failure in only one of the reftests. Just 38 pixels don't match, the test and ref are visually indistinguishable. I assume this is an artifact from the fact that the reftest is scaled as the drawing is otherwise exactly the same as non-scaling-stroke-01. Because of this I think having this one test fuzzy match on Android is the simplest answer.
Comment 2 Robert Longson 2012-05-20 00:38:23 PDT
Comment on attachment 625466 [details] [diff] [review]
patch

>diff --git a/layout/reftests/svg/reftest.list b/layout/reftests/svg/reftest.list
>--- a/layout/reftests/svg/reftest.list
>+++ b/layout/reftests/svg/reftest.list
>@@ -169,19 +169,18 @@ fails == inline-in-xul-basic-01.xul pass
> == marker-viewBox-01.svg marker-viewBox-01-ref.svg
> == mask-basic-01.svg pass.svg
> == mask-basic-02.svg mask-basic-02-ref.svg
> == mask-extref-dataURI-01.svg pass.svg
> == mask-containing-masked-content-01.svg pass.svg
> == mask-transformed-01.svg mask-transformed-01-ref.svg
> == nested-viewBox-01.svg pass.svg
> == nesting-invalid-01.svg nesting-invalid-01-ref.svg
>-# Bug 756405
>-random-if(Android) == non-scaling-stroke-01.svg non-scaling-stroke-01-ref.svg 
>-random-if(Android) == non-scaling-stroke-02.svg non-scaling-stroke-02-ref.svg 
>+== non-scaling-stroke-01.svg non-scaling-stroke-01-ref.svg 
>+fuzzy-if(Android,9,38) == non-scaling-stroke-02.svg non-scaling-stroke-02-ref.svg 
> == objectBoundingBox-and-clipPath.svg pass.svg
> # Bug 588684
> random-if(gtk2Widget) == objectBoundingBox-and-fePointLight-01.svg objectBoundingBox-and-fePointLight-01-ref.svg
> random-if(gtk2Widget) == objectBoundingBox-and-fePointLight-02.svg objectBoundingBox-and-fePointLight-02-ref.svg
> == objectBoundingBox-and-mask.svg pass.svg
> == objectBoundingBox-and-mask-02.svg pass.svg
> == objectBoundingBox-and-pattern-01a.svg objectBoundingBox-and-pattern-01-ref.svg
> == objectBoundingBox-and-pattern-01b.svg objectBoundingBox-and-pattern-01-ref.svg
Comment 4 Ed Morley [:emorley] 2012-05-20 23:39:46 PDT
https://hg.mozilla.org/mozilla-central/rev/443c0c79e54f

Note You need to log in before you can comment on or make changes to this bug.