Deleting messages does not work with POP3 accounts using the maildir store

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: steinspeicher, Unassigned)

Tracking

(Blocks 1 bug)

x86_64
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.46 Safari/536.5

Steps to reproduce:

* I set up a POP3 account to use the maildir storage format.
* I deleted a message by pressing the [Del] key


Actual results:

* The message was moved to trash, but the message list did not refresh properly
* Moving the mouse over a message in the list refreshed only this message's details (from, subject, date, etc.)
* After selecting another message and pressing [Del] multiple times again nothing happened. Further deletions were not possible.
* After navigating away to another folder and then back into the Inbox caused the messages to be listed properly, showing that only the first deletion was successful.


Expected results:

The messages should have beend moved to trash and the message list (Inbox) should have been refreshed to show the actual contents of the folder after the deletion of the message.
Reporter

Updated

7 years ago
Blocks: 58308

Comment 1

7 years ago
have you tried the latest nightly build?
Reporter

Comment 2

7 years ago
I tried it with today's earlybird.
Reporter

Comment 3

7 years ago
Just tested again with a completely fresh profile - same results.

Draging & dropping (even multiple) files to Trash works fine though. The problem only occurs when using the application's delete function (triggered by the "Delete" button, the "Delete message" menu item or the physical [Del] key).
Reporter

Comment 4

7 years ago
Still the same with earlybird 14.0a2 (2012-05-27)
Reporter

Comment 5

7 years ago
Would it help if I created a screencast demonstrating the problem?
(In reply to tom from comment #5)
> Would it help if I created a screencast demonstrating the problem?

Logs (as described at https://wiki.mozilla.org/MailNews:Logging ) from pop3 and msgdb would probably be more helpful.
Component: Folder and Message Lists → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → networking.pop
Reporter

Comment 7

7 years ago
Thanks for the hint. I just created logs for "pop3:5" and "msgdb:5" but there's no relevant information. Deletion of messages seems just not to be covered.

Also, it's not a POP3 but a storage issue. POP3-retrieval of messages itself is not involved here.
Reporter

Comment 8

7 years ago
To make sure that POP3 definitely isn't involved I just put some messages into a folder with "Local Folders". There's NO POP3 account linked with "Local Folders", but still: Deletion-Behaviour is exactly the same as in the Description (Comment #0).

Comment 9

7 years ago
yeah, deleting local messages has nothing to do with pop3 protocol.

There are changes that are in the nightly build (aka Daily) that aren't in early bird builds. Today, those changes should start appearing in early bird builds.
Reporter

Comment 10

7 years ago
thanks, i just tried with earlybird 15a2 and it seems to be fixed there while thunderbird 14 beta still shows the problem.
Reporter

Comment 11

7 years ago
fixed in version 15
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.