The field labels on mobile.twitter.com from the signin and signup pages are highlighted when tapped

VERIFIED FIXED in Firefox 19

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: AdrianT, Assigned: kats)

Tracking

15 Branch
Firefox 17
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox19 verified)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 625076 [details]
logs

Nightly 15.0a1 2012-05-18 / Aurora 14.0a2 2012-05-18
Device: HTC Desire Z / Motorola Droid Pro
OS: Android 2.3.3 / Android 2.3.4

Steps to reproduce:
1. Go to mobile.twitter.com.
2. Tap on the field labels on the signup page.
3. Go to the Signin page and tap on the field labels.

Expected results:
Nothing happens because there is no action to be taken with a single tap.

Actual results:
The label is highlighted and logs show a viewport recalculation. 

Please see the video capture: http://youtu.be/yi5npTpMQs0
Agreed, label elements that are not associated to a form element according to the rules at http://www.w3.org/TR/html5/the-label-element.html#the-label-element should not be clickable. Currently the browser.js code treats all label elements as clickable.

I don't think this is important enough to be a blocker though, so I won't nominate it for blocking-1.0.
Created attachment 639740 [details] [diff] [review]
Patch

Haven't tested this yet
Assignee: nobody → bugmail.mozilla
mobile.twitter.com has changed and now does have label elements associated with form elements. For the purposes of this bug I have a better test page at http://people.mozilla.org/~kgupta/bug/756433.html

My patch fixes the haptic feedback on clicking the unassociated labels, but they still highlight because we still call DOMUtils.setContentState(.., kStateActive) on them, and apparently they have an active state even when they are not associated with a form control. I'm not sure if that part is a bug or not. It does look odd from a user point of view, so maybe that should be fixed as well.
Attachment #639740 - Flags: review?(wjohnston)
Attachment #639740 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/4369826e4d93
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
It seems that the haptic feedback doesn't occur anymore on the un-clickable label onhttp://people.mozilla.org/~kgupta/bug/756433.html

Closing bug as verified fixed on:

Firefox 19.0a1 (2012-10-17)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
status-firefox19: --- → verified
You need to log in before you can comment on or make changes to this bug.