Last Comment Bug 756454 - [Azure] Use 2D texture for gradient realizations
: [Azure] Use 2D texture for gradient realizations
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Bas Schouten (:bas.schouten)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 07:07 PDT by Bas Schouten (:bas.schouten)
Modified: 2012-05-23 08:11 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use a 2D texture for gradient realizations. (3.64 KB, patch)
2012-05-18 07:07 PDT, Bas Schouten (:bas.schouten)
jmuizelaar: review+
Details | Diff | Splinter Review

Description Bas Schouten (:bas.schouten) 2012-05-18 07:07:00 PDT
Created attachment 625095 [details] [diff] [review]
Use a 2D texture for gradient realizations.

We currently use a 1D texture for gradient realizations and pretend in the shader it's 2D. This generates an Error from the D3D10 debug layer (although it appears to work fine). 1D textures are not supported in SM3.0 (i.e. non-D3D10 hardware), and since we're currently allowing D3D9 card users to force D2D the easiest solution is to use a 4096x1 2D texture. This patch makes that happen.
Comment 1 Bas Schouten (:bas.schouten) 2012-05-21 08:29:48 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/20cb25a8b8ba
Comment 2 Ed Morley [:emorley] 2012-05-21 11:12:53 PDT
Sorry, had to back out the push for Win debug crashes:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=a693c64dc64e

https://hg.mozilla.org/integration/mozilla-inbound/rev/b4e62a1e9809
Comment 3 Bas Schouten (:bas.schouten) 2012-05-21 22:11:50 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/64415d67fc2a
Comment 4 Ed Morley [:emorley] 2012-05-23 08:11:44 PDT
https://hg.mozilla.org/mozilla-central/rev/64415d67fc2a

Note You need to log in before you can comment on or make changes to this bug.