Last Comment Bug 756514 - Update documentation to reflect that sandbox.importFunction is no longer necessary
: Update documentation to reflect that sandbox.importFunction is no longer nece...
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 10:43 PDT by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2014-11-26 15:59 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Bobby Holley (:bholley) (busy with Stylo) 2012-05-18 10:43:12 PDT
I'm not sure what it used to do, but it doesn't do anything useful now post-compartments. We should update the docs to tell people they can just define the functions directly on the sandbox.
Comment 1 Blake Kaplan (:mrbkap) 2012-05-22 15:41:11 PDT
For what it's worth, this was necessary before we had automatic wrappers. Simply doing sandbox.function = chromeFunction was unsafe because there were ways of attacking chrome with the function object (or by passing evil objects to it). Now that we have automatic wrappers, importFunction is no longer necessary.
Comment 2 Mark Hammond [:markh] 2012-10-11 20:39:23 PDT
I just updated https://developer.mozilla.org/en-US/docs/Components.utils.Sandbox - I hope that was the only docs you had in mind, so I'm closing this.
Comment 3 Will Bamberg [:wbamberg] 2014-11-26 15:59:07 PST
I think dev-doc-needed can be removed from here as per markh's comment 2.

Note You need to log in before you can comment on or make changes to this bug.