Closed Bug 756557 Opened 10 years ago Closed 9 years ago

Add DX9 support for Windows 8 Metro builds

Categories

(Core :: Graphics, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 829127

People

(Reporter: bbondy, Unassigned)

References

Details

(Whiteboard: [metro-mvp][LOE:2])

Add DirectX 9 support for Windows 8 Metro builds when DirectX 10 is not available.
Assignee: netzen → nobody
Whiteboard: metro-beta
Blocks: 797201
I'm not 100% sure if this is that useful. At this point in time we don't know of any drivers on Windows 8 which support DX9 but have spotty support for DX10/11. Microsoft has deprecated DX9 pretty actively as far as I can tell.
Whiteboard: metro-beta → [metro-mvp]
Whiteboard: [metro-mvp] → [metro-mvp][LOE:2]
I should note in addition to my previous comment, it will add the requirement of D3D9 OMTC on Windows 8, which will provide an additional increase in workload.
Maybe we should morph this to be a bug about launching desktop firefox only when DX9 is not supported?
I'll post a new bug to provide a better fallback when DX10 is not supported. Based on what Bas said in Comment 1 and Comment 2 I'm going to WONTFIX this.  Please re-open if you have strong objections.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Depends on: 807669
Turns out this is already implemented in the path where we fallback to cairo as cairo will try to create a d3d 9.3 device.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 829127
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.