Input doesn't change to default after refresh page (F5)

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 46845
5 years ago
5 years ago

People

(Reporter: Wojciech, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Please copy the text to file and save as eg. bug.html and run this file in Firefox 12.0

<form action="" method="POST">
Select 1: <input type="radio" name="radio_select" value="0" checked />
Select 2: <input type="radio" name="radio_select" value="1" />

<select name="select">
	<option value="1">Example 1</option>
	<option value="2">Example 2</option>
	<option value="3">Example 3</option>
</select>
</form>


Actual results:

English (sorry for mistakes):
After selected other input  type radio then default (eg. Select 2) and refresh page (F5) input type radio not change to default (Select 1).
This is the same in select input.

Polish:
Po zmianie zaznaczenia inputa typu radio na inny i odświeżeniu strony pozostaje on na wybranym poprzednio, a powinien ustawić się na domyślny. Przykładowo: Zaznaczyłem Select 2, odświeżyłem stronę i nadal zaznaczone jest Select 2, a powinno zaznaczyć się pole domyślne (checked), czyli Select 1. We wszystkich przeglądarkach jakich testowałem (Chrome, Opera, Safari, IE9) tak się dzieje, w przypadku Firefoxa nie. Tak samo dzieje się w przypadku inputa select.


Expected results:

Input type radio/select should change to default where it is checked.
(Reporter)

Comment 1

5 years ago
Error concerns also input type checkbox.
use ctrl+F5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 46845
You need to log in before you can comment on or make changes to this bug.