Last Comment Bug 756798 - crash in js::mjit::Compiler::jsop_getprop
: crash in js::mjit::Compiler::jsop_getprop
Status: RESOLVED FIXED
: crash, regression, topcrash
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 15 Branch
: All All
: -- critical (vote)
: mozilla15
Assigned To: general
:
:
Mentors:
Depends on: 756851
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 10:38 PDT by Scoobidiver (away)
Modified: 2012-05-22 11:21 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Scoobidiver (away) 2012-05-19 10:38:09 PDT
It's #3 top crasher in today's build.
There's a spike in crashes from 15.0a1/20120519. The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e794cef56df6&tochange=642d1a36702f

Signature 	js::mjit::Compiler::jsop_getprop(js::PropertyName*, JSValueType, bool, bool) More Reports Search
UUID	0482be72-e86f-48db-b038-713a82120519
Date Processed	2012-05-19 17:05:05
Uptime	3526
Last Crash	58.8 minutes before submission
Install Age	3.4 hours since version was first installed.
Install Time	2012-05-19 13:43:33
Product	Firefox
Version	15.0a1
Build ID	20120519030527
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	AuthenticAMD family 16 model 6 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xffffffffdadadada
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x68d8, AdapterSubsysID: 00000000, AdapterDriverVersion: 8.961.0.0
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 	
EMCheckCompatibility	True	
Total Virtual Memory	4294836224
Available Virtual Memory	3593482240
System Memory Use Percentage	46
Available Page File	6202736640
Available Physical Memory	2279600128

Frame 	Module 	Signature 	Source
0 	mozjs.dll 	js::mjit::Compiler::jsop_getprop 	js/src/methodjit/Compiler.cpp:4863
1 	mozjs.dll 	js::mjit::Compiler::generateMethod 	js/src/methodjit/Compiler.cpp:2573
2 	mozjs.dll 	js::mjit::Compiler::performCompilation 	js/src/methodjit/Compiler.cpp:549
3 	mozjs.dll 	js::mjit::Compiler::compile 	js/src/methodjit/Compiler.cpp:146
4 	mozjs.dll 	js::mjit::CanMethodJIT 	js/src/methodjit/Compiler.cpp:1000
5 	mozjs.dll 	js::mjit::stubs::CrossChunkShim 	js/src/methodjit/InvokeHelpers.cpp:705
6 	KERNELBASE.dll 	SystemTimeToFileTime 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=js%3A%3Amjit%3A%3ACompiler%3A%3Ajsop_getprop%28js%3A%3APropertyName*%2C+JSValueType%2C+bool%2C+bool%29
https://crash-stats.mozilla.com/report/list?signature=js%3A%3Amjit%3A%3ACompiler%3A%3Ajsop_getprop
Comment 1 Scoobidiver (away) 2012-05-22 02:24:03 PDT
It's fixed by http://hg.mozilla.org/mozilla-central/rev/fb3036d9b9e6

Note You need to log in before you can comment on or make changes to this bug.