Last Comment Bug 756808 - Build failure: |Error remaking makefiles (ignored)| followed by |No rule to remake missing include file ../../../../../config/rules.mk|
: Build failure: |Error remaking makefiles (ignored)| followed by |No rule to r...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on: 751842
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 11:34 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2012-05-22 23:36 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (530 bytes, patch)
2012-05-20 00:25 PDT, Blair McBride [:Unfocused] (UNAVAILABLE)
Ms2ger: review-
Details | Diff | Splinter Review
Patch v2 (3.17 KB, patch)
2012-05-20 01:44 PDT, :Ms2ger (⌚ UTC+1/+2)
ayg: review+
Details | Diff | Splinter Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-05-19 11:34:21 PDT
Last night I saw this after a clobber build with d55df2c9c037 at the tip:

> nsIIDBIndex.idl
> nsIIndexedDatabaseManager.idl
> nsIWorkerTest.idl
> creating dom/tests/mochitest/webapps/Makefile
> creating dom/tests/mochitest/browser-frame/Makefile
> creating dom/tests/mochitest/pointerlock/Makefile
> creating dom/tests/mochitest/webapps/apps/Makefile
> creating dom/imptests/html/tests/submission/Mozilla/Makefile
> creating dom/imptests/failures/webapps/WebStorage/tests/submissions/Infraware/Makefile
> creating dom/imptests/webapps/WebStorage/tests/submissions/Makefile
> creating dom/imptests/failures/editing/selecttest/Makefile
> creating dom/imptests/failures/webapps/WebStorage/tests/submissions/Ms2ger/Makefile
> creating dom/imptests/failures/editing/conformancetest/Makefile
> creating dom/imptests/editing//Makefilecreating dom/imptests/webapps/DOMCore/tests/submissions/Opera/Makefile
> 
> creating dom/imptests/failures/webapps/DOMCore/tests/submissions/Opera/Makefile
> Error remaking makefiles (ignored)
> No rule to remake missing include file ../../../../../config/rules.mk
> c:\mc\config\makefiles\target_export.mk:67:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py -C editing/ export' failed, return code 2
> c:\mc\config\makefiles\target_export.mk:67:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py -C imptests export' failed, return code 2
> c:\mc\config\makefiles\target_export.mk:54:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py -C dom export' failed, return code 2
> c:\mc\config\rules.mk:609:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py export_tier_platform' failed, return code 2
> c:\mc\config\rules.mk:575:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py  tier_platform' failed, return code 2
Comment 1 Jared Wein [:jaws] (please needinfo? me) 2012-05-19 11:45:15 PDT
Another clobber-rebuild shows this similar error, although with slightly different timing:

>    Creating library js.lib and object js.exp
> tools_tier_js
> tier_platform:  xpcom modules/zlib modules/libpref intl netwerk  extensions/auth media/libjpeg modules/libbz2 other-licenses/bsdiff gfx/qcms ipc js/ipc hal js/xpconnect intl/chardet  modules/libjar st
> orage  extensions/cookie extensions/permissions  rdf js/jsd media/libvorbis  media/libopus  media/libnestegg media/libvpx media/libogg media/libtheora  media/libsydneyaudio  media/libspeex_resampler
> media/libcubeb  media/libpng uriloader caps parser gfx image dom view widget content editor layout docshell embedding xpfe/appshell  extensions/universalchardet accessible profile tools/profiler xpfe/
> components extensions/spellcheck security/manager modules/libmar toolkit extensions/pref services/crypto/component startupcache js/ductwork/debugger other-licenses/snappy toolkit/library xpcom/stub te
> sting/mochitest testing/xpcshell testing/tools/screenshot testing/peptest testing/mozbase
> export_tier_platform
> Generating LALR tables
> WARNING:pymake.data:httpserver XPI_NAME=
> Error remaking makefiles (ignored)
> No rule to remake missing include file ../../../../../config/rules.mk
> c:\mc\config\makefiles\target_export.mk:67:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py -C editing/ export' failed, return code 2
> c:\mc\config\makefiles\target_export.mk:67:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py -C imptests export' failed, return code 2
> c:\mc\config\makefiles\target_export.mk:54:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py -C dom export' failed, return code 2
> c:\mc\config\rules.mk:609:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py export_tier_platform' failed, return code 2
> c:\mc\config\rules.mk:575:0: command 'c:/mozilla-build/python/python.exe c:/mc/build/pymake/pymake/../make.py  tier_platform' failed, return code 2
Comment 2 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-05-19 15:32:47 PDT
I started getting this too, also on Windows/pymake - so presumably it's another pymake issue.
Comment 3 :Aryeh Gregor (away until August 15) 2012-05-19 23:10:00 PDT
This will have been caused by bug 751842.  I probably messed up the makefiles somehow -- I had no idea what I was doing.  This line strikes me as fishy, at a glance:

(In reply to Jared Wein [:jaws] from comment #0)
> > creating dom/imptests/editing//Makefilecreating dom/imptests/webapps/DOMCore/tests/submissions/Opera/Makefile

Notice the double slash after "editing".  What happens if you change dom/imptests/editing.mk from

DIRS += \
  editing/ \
  $(NULL)

to

DIRS += \
  editing \
  $(NULL)

i.e., removing the trailing slash after "editing"?  This is a total shot in the dark, but who knows, it might be right . . .
Comment 4 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-05-20 00:25:47 PDT
Created attachment 625464 [details] [diff] [review]
Patch v1

Yep, that was it.

(Oh god, how did I get here, I'm not good with /dom/)
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-05-20 01:44:04 PDT
Comment on attachment 625464 [details] [diff] [review]
Patch v1

Review of attachment 625464 [details] [diff] [review]:
-----------------------------------------------------------------

No, this is a generated file...
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-05-20 01:44:58 PDT
Created attachment 625470 [details] [diff] [review]
Patch v2
Comment 7 :Aryeh Gregor (away until August 15) 2012-05-20 02:14:31 PDT
Comment on attachment 625470 [details] [diff] [review]
Patch v2

LGTM.
Comment 9 Ed Morley [:emorley] 2012-05-20 23:39:16 PDT
https://hg.mozilla.org/mozilla-central/rev/b35ff1418287
Comment 10 Johnny Stenback (:jst, jst@mozilla.com) 2012-05-21 01:07:41 PDT
My build is still failing with the patch that landed here... I get:

make[3]: Entering directory `/home/jst/fast/work/tip/fb-rel/dom/imptests/editing'
Makefile:17: ../../../../../mozilla/config/rules.mk: No such file or directory
make[3]: *** No rule to make target `../../../../../mozilla/config/rules.mk'.  Stop.
make[3]: Leaving directory `/home/jst/fast/work/tip/fb-rel/dom/imptests/editing'
make[2]: *** [export] Error 2
make[2]: Leaving directory `/home/jst/fast/work/tip/fb-rel/dom/imptests'
make[1]: *** [export] Error 2
make[1]: Leaving directory `/home/jst/fast/work/tip/fb-rel/dom'
make: *** [default] Error 2

The reason being that there's one to many ../'s in the path to rules.mk. Why, I can't tell, but my builds fail nonetheless :(
Comment 11 Justin Wood (:Callek) 2012-05-21 02:22:01 PDT
(In reply to Johnny Stenback (:jst, jst@mozilla.com) from comment #10)
> My build is still failing with the patch that landed here... I get:
> 
> make[3]: Entering directory
> `/home/jst/fast/work/tip/fb-rel/dom/imptests/editing'
> Makefile:17: ../../../../../mozilla/config/rules.mk: No such file or
> directory
> make[3]: *** No rule to make target
> 
> The reason being that there's one to many ../'s in the path to rules.mk.
> Why, I can't tell, but my builds fail nonetheless :(

This looks like the build thinks it is trying to build a comm-central based app and not Firefox.

(which means it has ../mozilla/ by mistake) No idea why though, just figured I would point that out.
Comment 12 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2012-05-21 09:16:24 PDT
No, I don't think that's it. The trailing slash on editing/ was incorrect, but because of how we remake makefiles, I think you need to clobber that makefile. You should be able to `rm objdir/dom/imptests/Makefile` and rebuild.
Comment 13 Johnny Stenback (:jst, jst@mozilla.com) 2012-05-22 23:36:47 PDT
Thanks bsmedberg! Clobbering that makefile fixed the problem here! Marking this fixed again, and sorry for the confusion...

Note You need to log in before you can comment on or make changes to this bug.