Korean character styled bold

RESOLVED FIXED

Status

()

RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: channy, Assigned: m_kato)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 3 obsolete attachments)

(Reporter)

Description

7 years ago
Created attachment 625489 [details]
comparision Korean font with android default browser.

Korean character alway styled bold in Fennec aurora and beta.
This bug is similar with bug 754883. 

In case of chinese and japanese character is shown nomally.
Please check out other locale version.

* Tested phone: Samsung Galuxy SII
* Locale version: en-US, ko
(Reporter)

Comment 1

7 years ago
According to my investigation, in https://hg.mozilla.org/releases/mozilla-aurora/file/0984ec812496/modules/libpref/src/init/all.js#l2809

- pref("font.name.sans-serif.ko", "Droid Sans");
+ pref("font.name.sans-serif.ko", "Droid Sans Fallback");

In my phone, it works nicely on web page. But, about:config screen is still bold styled.
(Reporter)

Comment 2

7 years ago
Created attachment 625492 [details]
font styled bold in about:config
There is no Korean font in default android environment, so we don't set correct font name in prefs.js yet.

Channy, what korean font does Samsung or LG install?  We should add it to name-list.
(Reporter)

Comment 4

6 years ago
(In reply to Makoto Kato from comment #3)
> There is no Korean font in default android environment, so we don't set
> correct font name in prefs.js yet.
> 
> Channy, what korean font does Samsung or LG install?  We should add it to
> name-list.

I think that is not good to assign font name for each devices. In first, it's better to add values in mobile-l10n.js. 

- pref("font.name.sans-serif.ko", "Droid Sans");
+ pref("font.name.sans-serif.ko", "Droid Sans Fallback");
(Reporter)

Comment 5

6 years ago
Created attachment 631655 [details] [diff] [review]
font fallback for Korean
Attachment #631655 - Flags: review?(l10n)

Comment 6

6 years ago
I'm not sure I like changing fonts just per locale.

Also, this wouldn't help the multi-locale builds, which now contain Korean.
(Reporter)

Comment 7

6 years ago
(In reply to Axel Hecht [:Pike] from comment #6)
> I'm not sure I like changing fonts just per locale.
> 
> Also, this wouldn't help the multi-locale builds, which now contain Korean.

Okay. Makato, can you add this setting in https://hg.mozilla.org/releases/mozilla-aurora/file/0984ec812496/modules/libpref/src/init/all.js#l2809 ?

- pref("font.name.sans-serif.ko", "Droid Sans");
+ pref("font.name.sans-serif.ko", "Droid Sans Fallback");
(In reply to Channy Yun from comment #7)
> (In reply to Axel Hecht [:Pike] from comment #6)
> > I'm not sure I like changing fonts just per locale.
> > 
> > Also, this wouldn't help the multi-locale builds, which now contain Korean.
> 
> Okay. Makato, can you add this setting in
> https://hg.mozilla.org/releases/mozilla-aurora/file/0984ec812496/modules/
> libpref/src/init/all.js#l2809 ?
> 
> - pref("font.name.sans-serif.ko", "Droid Sans");
> + pref("font.name.sans-serif.ko", "Droid Sans Fallback");

We should use font.name-list.sans-serif.ko instead of.
Created attachment 633937 [details] [diff] [review]
fix v1
Attachment #631655 - Attachment is obsolete: true
Attachment #631655 - Flags: review?(l10n)
Attachment #633937 - Flags: review?(jdaggett)
(Reporter)

Comment 10

6 years ago
(In reply to Makoto Kato from comment #9)
> Created attachment 633937 [details] [diff] [review]
> fix v1

By my test, pref("font.name-list.sans-serif.ko", "Droid Sans Fallback"); is not working. Instead of, pref("font.name.sans-serif.ko", "Droid Sans Korean"); is still working as like Japanese setting. I tested Samsung Galuxy S, SII and LG optimus phone.

Comment 11

6 years ago
Looks good but I think 'Droid Sans' should be at the head of the list.  This should fix the bug but improve perf for cases where the 'Droid Sans' case includes support for Korean.  Given that makers seem to enjoy messing around with default fonts, I think that's definitely possible.

Updated

6 years ago
Attachment #633937 - Flags: review?(jdaggett) → review+
(Reporter)

Comment 12

6 years ago
(In reply to John Daggett (:jtd) (Away 15-22 June) from comment #11)
> Looks good but I think 'Droid Sans' should be at the head of the list.  This
> should fix the bug but improve perf for cases where the 'Droid Sans' case
> includes support for Korean.  Given that makers seem to enjoy messing around
> with default fonts, I think that's definitely possible.

Unfortunately, this patch cannot solve this problem. (You have to test in Korean version). According to my survery, Droid Sans Fallback(.ttf) is original Korean font.

Comment 13

6 years ago
Fallback uses all fonts in the font.name-list.xxx pref, so it will pick up Droid Sans Fallback if the characters are missing from Droid Sans.  But Droid Sans Fallback is a large font, it's always more optimal to use Droid Sans instead if possible.  Including it will *not* break the fix, it will merely insure that if a Korean maker includes glyphs for Korean in Droid Sans that we will pick that up instead.

Updated

6 years ago
Attachment #633937 - Flags: review+
(Reporter)

Comment 14

6 years ago
Created attachment 636570 [details]
Serif as default font on Galuxy Tab

Another strange thing is that default font on galaxy tab 8.9 is still Serif type(Batang-che) despite of setting sans-serif as a default.
(Reporter)

Comment 15

6 years ago
Jungshik, would you check this bug on Android?
(Reporter)

Comment 16

6 years ago
Makoto Kato's patch is working only serif font for Galuxy Note and Tab. It changes serif font to sans-serif font as a default. But, primary problem is solved only by to change font.name.sans-serif.ko to Droid Sans Fallback.
Hi!
I was so suprised about this bug, because I never meet with this bug - from nightly to stable!
I'm using Nexus S with ICS(4.0.4) and tested ko locale both Android and Firefox.
Here I attached screenshot with latest Aurora at now.
Created attachment 637105 [details]
Korean letters shown correctly.

about:config in Firefox for Android Aurora(15.0a2 2012-06-26).
The letters are not bold.
In Channy's screenshot, seems it doesn't use Droid Sans series, but I'm not sure.
I think Galaxy S2's different font set makes this problem.
Created attachment 637774 [details] [diff] [review]
fix v2

Although it isn't good way to add Droid Sans Fallback to font.name-sans-serif.ko, it is no way except to this, according to test result.

If feature version of Android adds korean font, we should modify this prefs.
Attachment #633937 - Attachment is obsolete: true
Attachment #637774 - Flags: review?(jdaggett)
Created attachment 637779 [details] [diff] [review]
fix v3
Assignee: nobody → m_kato
Attachment #637774 - Attachment is obsolete: true
Attachment #637774 - Flags: review?(jdaggett)
Attachment #637779 - Flags: review?(jdaggett)

Comment 22

6 years ago
Comment on attachment 637779 [details] [diff] [review]
fix v3

> +// Droid Sans Korean is nothing, but this is dummy
> +pref("font.name.sans-serif.ko", "Droid Sans Korean");

I think you mean "Droid Sans Korean may not be present"

> +pref("font.name-list.sans-serif.ko", "Roboto, Droid Sans, Droid Sans Fallback");

You should include "Droid Sans Korean" here too.

r+ with changes
Attachment #637779 - Flags: review?(jdaggett) → review+
(Reporter)

Comment 23

6 years ago
(In reply to John Daggett (:jtd) from comment #22)
> Comment on attachment 637779 [details] [diff] [review]
> fix v3
> 
> > +// Droid Sans Korean is nothing, but this is dummy
> > +pref("font.name.sans-serif.ko", "Droid Sans Korean");
> 
> I think you mean "Droid Sans Korean may not be present"
> 
> > +pref("font.name-list.sans-serif.ko", "Roboto, Droid Sans, Droid Sans Fallback");
> 
> You should include "Droid Sans Korean" here too.
> 
> r+ with changes

I did tests with this setting in Galuxy S, S2, Galuxy Note, but the problem is not fixed. I guess Droid Sans font has only bold type characters. (This setting means that only missing characters in Droid Sans are referred to Droid Sans Fallback. It's not this problem.)
(Reporter)

Comment 24

6 years ago
So, as following setting is working. Please consider it.

-pref("font.name-list.sans-serif.ko", "Roboto, Droid Sans, Droid Sans Fallback");
+pref("font.name-list.sans-serif.ko", "Roboto, Droid Sans Fallback, Droid Sans");
(In reply to Channy Yun from comment #23)
> I guess Droid Sans font has only bold type characters.

That's not true. Droid Sans doesn't has any type of Korean characters, and Droid Sans Fallback only include regular type of Korean characters. I mean, there's no bold type of Korean characters in any Droid Sans. 

As a result, Fennec can NOT show bold-styled Korean character in Nexus series. Should I open new bug report about it?
(Reporter)

Comment 26

6 years ago
(In reply to Channy Yun from comment #24)
> So, as following setting is working. Please consider it.
> 
> -pref("font.name-list.sans-serif.ko", "Roboto, Droid Sans, Droid Sans
> Fallback");
> +pref("font.name-list.sans-serif.ko", "Roboto, Droid Sans Fallback, Droid
> Sans");

How's going this bug?

Comment 27

6 years ago
Droid Sans Fallback comes only in a single weight (regular) and that's the only font in Google's reference build that covers Korean character. So, it's very strange that Korean characters are in bold no matter what font pref entries you have. 

Anyway, I'd have something like this:

font.name.sans-serif.ko => Roboto 
font.name-list.sans-serif.ko => "Korean fonts shipped with Korean Android device manufactures" followed by 'Droid Sans Fallback'

That way, in the presence of better Korean fonts on Samsung Galaxy S* or other Android devices sold in Korea, one of them will be used instead of Droid Sans Fallback (whose Korean quality is not that great). 

BTW, Korean fonts listed before DSF should cover the full set of 11,172 syllables. Otheriwse, there would be a ransom note effect because some of characters can be picked up from Droid Sans Fallback.
(In reply to Jungshik Shin from comment #27)
> Droid Sans Fallback comes only in a single weight (regular) and that's the
> only font in Google's reference build that covers Korean character. So, it's
> very strange that Korean characters are in bold no matter what font pref
> entries you have. 
It's true there is only regular Korean characters in Droid Sans Fallback. The reason Korean characters are styled bold is another Korean font by manufacturer is shown instead of Droid Sans Fallback.

Actually, styled bold is symptom only in Samsung's phones(I guess Helvetica S bold or Samsung Gothic bold is used instead of Droid Sans Fallback). Other phones not manufactured by Samsung(ex SKY) will show strange fonts. So I suggent to change title of bug report, Channy.

I think the best way is through out every font preference and just follow android system's font matching.

Comment 29

6 years ago
I want this.

add "Droad Sans Fallback" before "Droid Sans" to "font.name-list.sans-serif.x-unicode", not ".ko".

today, many korean website makes unicode, so only ".ko" is not insufficient.

Comment 30

6 years ago
Korean is not showing up bold on my 4.1.2 device, but they are showing up in some strange italic style. All my .ko and unicode settings are default. I will upload a screenshot of google's own homepage on my device. Android and Chrome browsers show up normal.

Comment 31

6 years ago
Created attachment 734343 [details]
Default Italics font

Font is showing up as italic by default
(Reporter)

Comment 32

6 years ago
I tested as following major devices:
1) Samsung Galuxy S1, S2, S3, S4, GaluxyTab 10, Galuxy Note 1, 2
2) LG Optimus LTE, G, G Pro 

If your device has same problem, please test as following preferences.
pref("font.name.sans-serif.ko", "Droid Sans Korean");
pref("font.name-list.sans-serif.ko", "Open Sans, DroidSansFallback");
(In reply to Channy Yun [:channy] from comment #32)
> I tested as following major devices:
> 1) Samsung Galuxy S1, S2, S3, S4, GaluxyTab 10, Galuxy Note 1, 2
> 2) LG Optimus LTE, G, G Pro 
> 
> If your device has same problem, please test as following preferences.
> pref("font.name.sans-serif.ko", "Droid Sans Korean");
> pref("font.name-list.sans-serif.ko", "Open Sans, DroidSansFallback");

Channy, we haved already add some font define sto prefs.js ("Droid Sans Fallback" and "NanumGothic" to Firefox 23 for Korean.

Could you test this on Firefox Nightly?

Updated

6 years ago
Flags: needinfo?(channy)
(Reporter)

Comment 34

5 years ago
I tested several devices of the latest version and confirmed to be solved.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(channy)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.